31 October 2013

Cara Upload Drag and Drop File di Ubuntu


Terkadang kita bingung sob kalo ada di suatu web yang menyediakan drag and drop untuk mengupload file, Drag here, biasanya gitu, itu seakan ngeledek bagi saya, kenapa? karena susah bro di ubuntu di drag eh malah ga bisa, apa lagi salah satu web komunitas seperti koding.com hanya bisa mengupload via drag and drop file, nyelekit dah, Eittss tunggu dulu, bukan anak linux namanya kalo cuman hanya

29 October 2013

Cara Install BBM Android di Ubuntu


Oke sob masih dalam isu BBM yang kian memanas hehehee, saatnya memposting Cara install BBM di Ubuntu nih sob, kali aja ada yang mampir kesini, senernya caranya sama ga ada bedanya dengan cara install dengan windows, bedanya di linux lebih cepet jalannya dan masalah yang timbul itu minim itu aja yang saya rasakan hehehehe, langsung saja sob, persiapkan alat-alat ini



Download



1. VirtualBox 

25 October 2013

How To: Install Aplikasi BlackBerry Messenger for Android di Ubuntu mu


Well, beberapa hari yang lalu (sampai tulisan ini ditulis) aplikasi BlackBerry Messenger (BBM) Cross Platform menjadi booming di kalangan pengguna Sistem Operasi Mobile. BBM yang dulu hanya eksklusif di perangkat BlackBerry, kini hadir di perangkat android dan iOS. Sebagian besar pengguna android sangat antusias dalam mencoba untuk memasang aplikasi BBM ini.

Namun sayang beberapa mengalami kendala, salah satunya adalah pengguna android yang masih memakai versi gingerbread dan yang masih menggunakan arsitektur ARMv6. Syarat tertulis untuk menginstall BBM di Google's Playstore adalah minimal menggunakan versi android ICS (4.0.x), sedangkan "syarat tak tertulisnya" adalah penggunaan arsitektur CPU minimal ARMv7 (di dalam file apk BBM, setelah saya lihat, ada code armeabi-v7). Lalu bagaimana dengan nasib ratusan ribu, bahkan jutaan user android yang device nya masih memakai arsitektur ARMv6? tenang saja, masih banyak jalan menuju Roma. 

Kamu dapat menggunakan aplikasi BBM lewat PC/Laptop, khusus pada tulisan ini saya akan menjelaskan tutorial penggunaanya di Linux (terutama Ubuntu). Untuk distro Linux yang lainnya, hampir sama step by step dan apa saja yang dibutuhkan. Kita akan menggunakan Android SDK (Software Development Kit) yang didalamnya terdapat tools penting untuk memakai aplikasi BBM ini, yaitu Android Virtual Device (AVD). Meskipun ada cara lain yang dapat dipergunakan untuk "bermain BBM" di PC/Laptop, akan tetapi cara ini merupakan cara (emulator) yang paling manjur untuk digunakan di hampir semua PC/Laptop.
Untuk hanya sekedar menggunakan AVD, kita tidak perlu mendownload full SDK dan tools, kita cukup menggunakan beberapa saja. Berikut adalah step by step tutorial nya :
1. Install JDK (java develompent kit), kita akan menggunakan openJDK.
Buka terminal, copy-paste kan  perintah berikut :
sudo apt-get install openjdk-6-jre openjdk-6-jdk icedtea6-plugin

2. Jika kamu memakai sistem operasi 64-bit, perlu untuk menginstall library 32-bit
sudo apt-get install ia32-libs

3. Download dan install Android SDK, sesuaikan dengan sistem operasi nya.
Download disini, cukup download SDK Tools Only.

4. Buat folder untuk android SDK nya dan untar file hasil download tadi, contoh :
mkdir ~/development
cd ~/Downloads
tar -zxvf android-sdk_r22.1.1-linux.tgz
mv ~/Downloads/android-sdk-linux ~/development/

5. Setup ADB/Fastboot
cd ~/development/android-sdk-linux/tools
./android

yang perlu kamu install adalah Extras, Android SDK Tools, Android SDK Platform-Tools, Android SDK Build-tools, dan Virtual Device image, dalam hal ini saya menginstall versi Android 4.3 (API 18) perlu diingat bahwa untuk menjalankan aplikasi BBM diperlukan API 15 (Android 4.0.3). file yang perlu untuk diinstall adalah SDK Platform, Samples for SDK, ARM EABI v7a System Image, dan Google APIs. cukup itu saja.

Klik untuk memperbesar gambar
setelah selesai, buka jendela terminal baru ketikkan:
sudo gedit .bashrc
masukkan tulisan ini di akhir halaman 
#Android PATHS
export PATH=$PATH:~/development/android-sdk-linux/tools
export PATH=$PATH:~/development/android-sdk-linux/platform-tools
Setelah step diatas selesai, buka tools di toolbar android SDK, klik AVD, buat baru (new) setting seadanya dan klik start.

Klik untuk memperbesar gambar
6. Download disini untuk file APK BBM.
copy-pastekan di folder home/development/android-sdk-linux/platform-tools
buka terminal di lokasi folder tersebut, ketik :
./adb install BBM_1_0_0_72.apk
tunggu sampai proses instalasi selesai, lalu pindah ke jendela AVD.

Proses start up AVD memang cukup lama, terutama bagi PC/Laptop yang hardware nya mepet (khusus untuk yang hardware nya mepet, pakai android API yang ter rendah yaitu 15, karena semakin rendah semakin ringan), ditunggu saja sekitar 5-15 menit. Setelah itu klik icon BBM, maka akan memasuki halaman untuk antrian email (EDIT. info terbaru bahwa BlackBerry Ltd. sudah meniadakan antrian email). Setelah tembus, segera buat Blackberry ID apabila kamu belum mempunyai BB ID, atau sign in apabila kamu sudah mempunyai sebelumnya. Kemudian kamu akan mendapat PIN BBM yang dapat kamu pergunakan.




EDIT (01/11/13) : jika ingin menginstall multiple aplikasi BBM / Multi PIN di 1 device/ emulator, dapat download APK yang telah saya upload disini (support max. 5 BB ID/PIN, lebih dari itu akan terasa berat untuk di running) dan APK tersebut support landscape mode. Ketika tulisan ini ditulis, aplikasi BBM resmi hanya bisa portrait mode :D

Selamat kamu sudah dapat menggunakan BlackBerry Messenger di Linux (ubuntu) Machine kamu.
RUMIT??? yang kita butuhkan adalah PROSES, bukannya HASIL AKHIR semata. Itulah yang membedakan UNIX/Linux dengan sistem operasi lainnya. :)

Semoga Bermanfaat.

24 October 2013

Install Android Di Komputer Dengan Virtualbox


Helo ketemu lagi :) jangan bosen ya.. plis.

Selamat pagi semua, saya suka mngucapkan selamat pagi kapanpun itu karena, pagi itu bisa memberi kita banyak inspirasi dan awal dimana kita memupuk semangat untuk beraktivitas hingga akhirnya kita memejamkan mata saat malam tiba.

Wah.. jadi berorasi. Ceritanya saya baru saja menginstall aplikasi android yang familiar, Whatsapp di komputer dengan ubuntu 13.10. Sebagai frontend-nya saya menggunakan Virtualbox.

Screnshot di Android - Virtualbox, Ngobrol sendiri dengan nomor yg lain :)
Kebetulan sudah cukup lama saya memiliki file .iso android 4.1 yang berhasil saya instalkan di Virtualbox pada Ubuntu 13.10 (setelah diupgrade). Karena Whatsapp tersebut adalah yang saya dapatkan dari google play.

Screnshot di Lenovo P770i
Step installasi Whatsapp di Android - Virtualbox

  1. Pastikan kita telah mengaktivkan akun google
  2. Menuju Google Play di Android
  3. Cari Whatsapp dan install
  4. Daftarkan nomor kita
  5. Masukkan kode verifikasi yang dikirimkan whatssapp ke nomor kita
  6. Bisa juga kita mendapatkan kode tersebut dengan memilih tap to call
  7. Setelah selesai, tambahkan kontak & Whatsapp telah siap digunakan

Nah begitulah, simple dan tidak ribet. Mungkin yang agak ribet adalah saat kita mencoba untuk mendapat kode verifikasi yang dikirim ke handset kita.

Tapi selama kita mau berusaha, disitu akan ada jalan. cie.. cie.. cie.. :)


23 October 2013

Seting VLC Dengan Skin Non Standar

VLC Skin
Apabila kita merasa bosan dengan tampilan VLC media player, sebaiknya kita berfikir untuk menggunakan skin non standar.

Sebenarnya, seperti halnya winamp di windows dan beberapa media player juga mendukung penggunaan skin, maka sebenarnya VLC juga bisa menggunakan skin yang bukan standar.

Caranya untuk menggunakan skin di VLC
  • Pertama-tama kita bisa mendownload skin di sini
  • Buka VLC dan pilih Preference > Use custom skin
  • Extract skin yang tadi kita download dan simpan ke folder /usr/share/vlc/skins2
Untuk mengganti skin, pilihlah menu Interface > Choose Skin

Yap, segitu saja, selanjutnya silahkan untuk mencoba :)

Baca juga : Tips Mengatasi Error VLC

VLC Error : "skins2 interface error: no skins found : exiting"

Vlc adalah salah satu media player terbaik. Saya juga menginstallnya di ubuntu dengan

sudo apt-get install vlc

Vlc ini mampu untuk memainkan berbagai format media yang ada, sehingga menjadikannya sebagai media player yang powerfull.

Vlc tersedia bebas untuk berbagai platform termasuk windows, linux, mac OS X dan bisa memainkan berbagai format media seperti :
  • MPEG-2
  • DivX
  • H.264
  • MKV
  • WebM
  • WMV
  • MP3
Apabila kita mengalami error  "skins2 interface error: no skins found : exiting" dimana tidak ditemukan skin yang ada dalam konfigurasinya.

Untuk mengatasi masalah tersebut, kita bisa  mengatasinya  dengan menghapus folder vlc yang ada di /home/user/.config/vlc

Kita bisa menghapus folder vlc tersebut, karena nantinya setelah folder itu dihapus dan kita kembali menjalankan vlc, maka secara otomatis vlc akan membuat konfigurasi ulang ditempat yang sama dengan setingan yang standar.

Demikianlah, cara yang saya gunakan ketika vlc mengalami error "skins2 interface error: no skins found : exiting".

Untuk uji coba, bisa juga kita me-rename folder /home/user/.config/vlc menjadi /home/user/.config/folder-lain, maka ketika vlc dijalankan, akan secara otomatis kembali membuat konfigurasi seperti yang tadi disebutkan.


Nah, gimana? Berani bereksperimen? :)

Mempercantik Tampilan Desktop

Salah satu cara bagi kita untuk bisa mempercantik tampilan desktop adalah dengan menginstall conky.

Conky adalah semacam tool atau program untuk linux, BSD, Free BSD yang bisa menampilan  informasi :
  • CPU
  • Suhu
  • Hardisk
  • Jam dan tanggal
  • File Sistem
  • dll

Sehingga dengan menggunakan conky kita bisa memonitor sistem yang sedang berjalan.

Karena conky memiliki banyak theme dan juga tampilan yang menarik, sehingga banyak orang yang tertarik untuk menginstallnya di komputer mereka. Termasuk saya :)

Installasi

Lalu bagaimana cara kita untuk enginstall conky? Pastikan kita memiliki koneksi internet yang lancar.  Pastikan sebelum kita menginstall conky, terlebih dahulu untuk menginstall LM-Sensores :

sudo apt-get install lm-sensors

Setelah itu jalankan dengan pengaturan dengan

sudo sensors-detect

Setelah berhasil terinstall, langkah selanjutnya adalah dengan menginstall conky di terminal :
  1.  sudo apt-get install conky-all
  2.  Download Conky Loa disini
  3.  Extraklah file hasil download tadi, kemudian caril & extrakah  dari hasil extract tadi Conky ubuntu-loa.tar.gz


Masuk ke folder hasil extract dan rename conkyec menjadi .conkyrc (hiden, untuk melihatnya, dari nautilus tekan Ctrl + H)

  1. Copy .conkyrc ke folder home
  2. Buat folder .conky lalu copy fila lainnya (clock_rings.lua dan new-ubuntu-logo.png) ke folder .conky tersebut

Edit file .conkyrc di home dan replace :

/~.lua/scripts/clock_rings.lua
 menjadi
 ~/.conky/clock_rings.lua

Conky Manager
Untuk menjalankan, dari terminal ketikkan conky

Supaya kita mudah dalam melakukan pengaturan, sebaiknya install juga conky-manager, dengan cara :

sudo apt-add-repository ppa:teejee2008/ppa
sudo apt-get update
sudo apt-get install conky-manager


Setelah kita selesai, maka bisa melakukan pengaturannya dengan menggunakan perintah conky-manager dari terminal ataupun menggunakan keyword conky manager dari dash ubuntu.







Cara Install Adobe Air di Ubuntu


Pagi, siang, sore, malam sob. Oke buat para pengguna ubuntu ada dua kabar yang akan saya sampaikan, yang pertama kabar buruk, yaitu adobe air sudah tidak lagi mendukung atau mensuport linux, yang kedua kabar baiknya ada cara lain untuk menginsall adobe air di linux, ehehe istilahnya banyak jalan menuju pelaminan *eh, oke sob kita langsung saja.



NB : Saya pake 13.04







Untuk 32-Bit

18 October 2013

Tutorial Installasi Ubuntu Server Di Virtual Box / VM Ware

Bonjour! Kita ketemu lagi di blog Tutorial Linux Ubuntu Berbahasa Indonesia. Kalau diingat-ingat di blog ini saya sudah cukup banyak memberikan tutorial-tutorial seputar linux khususnya ubuntu. Tapi, rasanya ada yang kurang :D

Rasanya saya melewatkan hal paling mendasar dalam menguasai linux ubuntu, jika tanpa memberikan tutorial installasi ubuntu server. Pada artikel ini saya menyajikan tutorial yang berbeda, proses installasi linux ubuntu server  ini akan saya lakukan di virtual box. Jika anda kebetulan sedang mencari panduan installasi linux ubuntu anda tidak salah tempat berkunjung. Saya sengaja tidak memasukkan video kedalam blog ini dikarenakan beberapa alasan. Untuk lebih jelasnya silahkan kunjungi video ini di youtube.

Tutorial Installasi Linux Ubuntu Server Di VirtualBox



Semoga bermanfaat,
Salam penguin! :)

Upgrade Online Ubuntu 13.04 ke 13.10

Selain melakukan installasi/upgrade melalui cd/dvd installer yang telah kita download, kita juga bisa melakukan upgrade ubuntu 13.04 ke 13.10 secara online.

Apabila kita ingin melakukan upgrade secara online, pastikan bahwa kita memiliki koneksi internet yang cepat dan stabil, karena upgrade secara online bisa memakan waktu yang lebih lama dibanding kita melakukan upgrade secara offline. Berikut cara untuk melakukan upgrade secara online :

1. Jalankan update manager dari dash ubuntu
 

2. Check for updates, click pada check button untuk mengetahui adanya update terbaru, jika ditemukan click check sekali lagi setelah update komplet kemudian klik  Upgrade button untuk menginstall Ubuntu 13.10 secara online


3. Install/Upgrade, akan ada window Welcome to Ubuntu 13.10 'Saucy Salamander' klik Upgrade untuk memulai.


Tunggu sampai proses upgrading selesai, lamanya tergantung koneksi internet yang kita miliki.

Memanggil The Matrix Ke Terminal Linux


Hey guys :) wow

Saya lagi ingat film The Matrix yang ada Keanu Reave-nya itu tuh... Ngomong-ngomong tentang The Matrix, di linux juga ada screensaver bertema The Matrix dengan deretan teks yang meluncur dari atas kebawah layar.

Meskipun sederhana, tapi menurutku itu keren. Keren banget.

Nang karena itu keren, makanya yuk kita coba panggil The Matrix ke terminal kita.

Caranya?

1. Install cmatrix dengan sudo apt-get install cmatrix
2. Panggil The Matrix dengan cmatrix

Nah begitulah guys. Simple kan? Ternyata linux memiliki perintah/program yang iseng tapi keren juga.

Selamat menikmati The Matrix. Wah Linux gak bikin linu juga rupanya.

Ubuntu 13.10 Bisa di Download


Untuk pengguna Ubuntu, saat ini telah bisa mendownload versi terbaru dari sistem operasi berbasis linux yang paling populer ini.

Yap, Ubuntu 13.10 Saucy Salamander, bisa kamu download langsung dari situs resmi ubuntu. Langsung aja klik Get Ubuntu 13.10 now!

Dengan mengusung tagline Smarter and faster, ubuntu 13.10 ini memiliki beberapa varian untuk desktop, server, smartphone dan juga cloud computing.

Gimana? Penasaran dengan Ubuntu 13.10 terbaru? Gak usah banyak mikir dah, download dan coba rasakan :)

15 October 2013

Cara Setting Load Balancing Mikrotik Metode PPC

Load Balance / Load Balancing Mikrotik adalah sebuah teknik atau metode untuk membagi beban ke dalam beberapa jalur (link) sehingga penggunaan jalur (link) menjadi lebih baik. Load balance Mikrotik Sebelumnya sudah pernah saya bahas pada artikel ini Load Balance / Load Balancing Mikrotik.


Selanjutnya pada artikel ini akan saya bahas tentang cara setting load balance mikrotik meggunakan metode PPC. Karena keterbatasan waktu dan peralatan, Tutorial Load Balance Mikrotik kali ini saya ambil dari web mikrotik.co.id sebagai berikut :

Selama ini banyak dari kita yang beranggapan salah, bahwa dengan menggunakan loadbalance dua jalur koneksi , maka besar bandwidth yang akan kita dapatkan menjadi dua kali lipat dari bandwidth sebelum menggunakan loadbalance (akumulasi dari kedua bandwidth tersebut). Hal ini perlu kita perjelas dahulu, bahwa loadbalance tidak akan menambah besar bandwidth yang kita peroleh, tetapi hanya bertugas untuk membagi trafik dari kedua bandwidth tersebut agar dapat terpakai secara seimbang.

Dengan artikel ini, kita akan membuktikan bahwa dalam penggunaan loadbalancing tidak seperti rumus matematika 512 + 256 = 768, akan tetapi 512 + 256 = 512 + 256, atau 512 + 256 = 256 + 256 + 256.

Pada artikel ini kami menggunakan RB433UAH dengan kondisi sebagai berikut :
1.    Ether1 dan Ether2 terhubung pada ISP yang berbeda dengan besar bandwdith yang berbeda. ISP1 sebesar 512kbps dan ISP2 sebesar 256kbps.
2.    Kita akan menggunakan web-proxy internal dan menggunakan openDNS.
3.    Mikrotik RouterOS anda menggunakan versi 4.5  karena fitur PCC mulai dikenal pada versi 3.24.

Jika pada kondisi diatas berbeda dengan kondisi jaringan ditempat anda, maka konfigurasi yang akan kita jabarkan disini harus anda sesuaikan dengan konfigurasi untuk jaringan ditempat anda.

Konfigurasi Dasar

Berikut ini adalah Topologi Jaringan dan IP address yang akan kita gunakan
/ip address
add address=192.168.101.2/30 interface=ether1
add address=192.168.102.2/30 interface=ether2
add address=10.10.10.1/24 interface=wlan2
/ip dns
set allow-remote-requests=yes primary-dns=208.67.222.222 secondary-dns=208.67.220.220


Untuk koneksi client, kita menggunakan koneksi wireless pada wlan2 dengan range IP client 10.10.10.2 s/d 10.10.10.254 netmask 255.255.255.0, dimana IP 10.10.10.1 yang dipasangkan pada wlan2 berfungsi sebagai gateway dan dns server dari client. Jika anda menggunakan DNS dari salah satu isp anda, maka akan ada tambahan mangle yang akan kami berikan tanda tebal

Setelah pengkonfigurasian IP dan DNS sudah benar, kita harus memasangkan default route ke masing-masing IP gateway ISP kita agar router meneruskan semua trafik yang tidak terhubung padanya ke gateway tersebut. Disini kita menggunakan fitur check-gateway berguna jika salah satu gateway kita putus, maka koneksi akan dibelokkan ke gateway lainnya.
/ip route
add dst-address=0.0.0.0/0 gateway=192.168.101.1 distance=1 check-gateway=ping
add dst-address=0.0.0.0/0 gateway=192.168.102.1 distance=2 check-gateway=ping


Untuk pengaturan Access Point sehingga PC client dapat terhubung dengan wireless kita, kita menggunakan perintah
/interface wireless
set wlan2 mode=ap-bridge band=2.4ghz-b/g ssid=Mikrotik disabled=no


Agar pc client dapat melakukan koneksi ke internet, kita juga harus merubah IP privat client ke IP publik yang ada di interface publik kita yaitu ether1 dan ether2.
/ip firewall nat
add action=masquerade chain=srcnat out-interface=ether1
add action=masquerade chain=srcnat out-interface=ether2


Sampai langkah ini, router dan pc client sudah dapat melakukan koneksi internet. Lakukan ping baik dari router ataupun pc client ke internet. Jika belum berhasil, cek sekali lagi konfigurasi anda.

Webproxy Internal
Pada routerboard tertentu, seperti RB450G, RB433AH, RB433UAH, RB800 dan RB1100 mempunyai expansion slot (USB, MicroSD, CompactFlash) untuk storage tambahan. Pada contoh berikut, kita akan menggunakan usb flashdisk yang dipasangkan pada slot USB. Untuk pertama kali pemasangan, storage tambahan ini akan terbaca statusnya invalid di /system store. Agar dapat digunakan sebagai media penyimpan cache, maka storage harus diformat dahulu dan diaktifkan Nantinya kita tinggal mengaktifkan webproxy dan set cache-on-disk=yes untuk menggunakan media storage kita. Jangan lupa untuk membelokkan trafik HTTP (tcp port 80) kedalam webproxy kita.

/store disk format-drive usb1
/store
add disk=usb1 name=cache-usb type=web-proxy
activate cache-usb

/ip proxy
set cache-on-disk=yes enabled=yes max-cache-size=200000KiB port=8080

/ip firewall nat
add chain=dstnat protocol=tcp dst-port=80 in-interface=wlan2 action=redirect to-ports=8080



Pengaturan Mangle
Pada loadbalancing kali ini kita akan menggunakan fitur yang disebut PCC (Per Connection Classifier). Dengan PCC kita bisa mengelompokan trafik koneksi yang melalui atau keluar masuk router menjadi beberapa kelompok. Pengelompokan ini bisa dibedakan berdasarkan src-address, dst-address, src-port dan atau dst-port. Router akan mengingat-ingat jalur gateway yang dilewati diawal trafik koneksi, sehingga pada paket-paket selanjutnya yang masih berkaitan dengan koneksi awalnya akan dilewatkan  pada jalur gateway yang sama juga. Kelebihan dari PCC ini yang menjawab banyaknya keluhan sering putusnya koneksi pada teknik loadbalancing lainnya sebelum adanya PCC karena perpindahan gateway.

Sebelum membuat mangle loadbalance, untuk mencegah terjadinya loop routing pada trafik, maka semua trafik client yang menuju network yang terhubung langsung dengan router, harus kita bypass dari loadbalancing. Kita bisa membuat daftar IP yang masih dalam satu network router dan  memasang mangle pertama kali sebagai berikut

/ip firewall address-list
add address=192.168.101.0/30 list=lokal
add address=192.168.102.0/30 list=lokal
add address=10.10.10.0/24 list=lokal

/ip firewall mangle
add action=accept chain=prerouting dst-address-list=lokal in-interface=wlan2 comment=”trafik lokal”
add action=accept chain=output dst-address-list=lokal


Pada kasus tertentu, trafik pertama bisa berasal dari Internet, seperti penggunaan remote winbox atau telnet dari internet dan sebagainya, oleh karena itu kita juga memerlukan mark-connection untuk menandai trafik tersebut agar trafik baliknya juga bisa melewati interface dimana trafik itu masuk
/ip firewall mangle
add action=mark-connection chain=prerouting connection-mark=no-mark in-interface=ether1 new-connection-mark=con-from-isp1 passthrough=yes comment=”trafik dari isp1”
add action=mark-connection chain=prerouting connection-mark=no-mark in-interface=ether2 new-connection-mark=con-from-isp2 passthrough=yes comment=”trafik dari isp2”


Umumnya, sebuah ISP akan membatasi akses DNS servernya dari IP yang hanya dikenalnya, jadi jika anda menggunakan DNS dari salah satu ISP anda, anda harus menambahkan mangle agar trafik DNS tersebut melalui gateway ISP yang bersangkutan bukan melalui gateway ISP lainnya. Disini kami berikan mangle DNS ISP1 yang melalui gateway ISP1. Jika anda menggunakan publik DNS independent, seperti opendns, anda tidak memerlukan mangle dibawah ini.
/ip firewall mangle
add action=mark-connection chain=output comment=dns dst-address=202.65.112.21 dst-port=53 new-connection-mark=dns passthrough=yes protocol=tcp comment=”trafik DNS citra.net.id”
add action=mark-connection chain=output dst-address=202.65.112.21 dst-port=53 new-connection-mark=dns passthrough=yes protocol=udp
add action=mark-routing chain=output connection-mark=dns new-routing-mark=route-to-isp1 passthrough=no


Karena kita menggunakan webproxy pada router, maka trafik yang perlu kita loadbalance ada 2 jenis. Yang pertama adalah trafik dari client menuju internet (non HTTP), dan trafik dari webproxy menuju internet. Agar lebih terstruktur dan mudah dalam pembacaannya, kita akan menggunakan custom-chain sebagai berikut :
/ip firewall mangle
add action=jump chain=prerouting comment=”lompat ke client-lb” connection-mark=no-mark in-interface=wlan2 jump-target=client-lb
add action=jump chain=output comment=”lompat ke lb-proxy” connection-mark=no-mark out-interface=!wlan2 jump-target=lb-proxy


Pada mangle diatas, untuk trafik loadbalance client pastikan parameter in-interface adalah interface yang terhubung dengan client, dan untuk trafik loadbalance webproxy, kita menggunakan chain output dengan parameter out-interface yang bukan terhubung ke interface client. Setelah custom chain untuk loadbalancing dibuat, kita bisa membuat mangle di custom chain tersebut sebagai berikut
/ip firewall mangle
add action=mark-connection chain=client-lb dst-address-type=!local new-connection-mark=to-isp1 passthrough=yes per-connection-classifier=both-addresses:3/0 comment=”awal loadbalancing klien”
add action=mark-connection chain=client-lb dst-address-type=!local new-connection-mark=to-isp1 passthrough=yes per-connection-classifier=both-addresses:3/1
add action=mark-connection chain=client-lb dst-address-type=!local new-connection-mark=to-isp2 passthrough=yes per-connection-classifier=both-addresses:3/2
add action=return chain=client-lb comment=”akhir dari loadbalancing”

/ip firewall mangle
add action=mark-connection chain=lb-proxy dst-address-type=!local new-connection-mark=con-from-isp1 passthrough=yes per-connection-classifier=both-addresses:3/0 comment=”awal load balancing proxy”
add action=mark-connection chain=lb-proxy dst-address-type=!local new-connection-mark=con-from-isp1 passthrough=yes per-connection-classifier=both-addresses:3/1
add action=mark-connection chain=lb-proxy dst-address-type=!local new-connection-mark=con-from-isp2 passthrough=yes per-connection-classifier=both-addresses:3/2
add action=return chain=lb-proxy comment=”akhir dari loadbalancing”


Untuk contoh diatas, pada loadbalancing client dan webproxy menggunakan parameter pemisahan trafik pcc yang sama, yaitu both-address, sehingga router akan mengingat-ingat berdasarkan src-address dan dst-address dari sebuah koneksi. Karena trafik ISP kita yang berbeda (512kbps dan 256kbps), kita membagi beban trafiknya menjadi 3 bagian. 2 bagian pertama akan melewati gateway ISP1, dan 1 bagian terakhir akan melewati gateway ISP2. Jika masing-masing trafik dari client dan proxy sudah ditandai, langkah berikutnya kita tinggal membuat mangle mark-route yang akan digunakan dalam proses routing nantinya
/ip firewall mangle
add action=jump chain=prerouting comment=”marking route client” connection-mark=!no-mark in-interface=wlan2 jump-target=route-client
add action=mark-routing chain=route-client connection-mark=to-isp1 new-routing-mark=route-to-isp1 passthrough=no
add action=mark-routing chain=route-client connection-mark=to-isp2 new-routing-mark=route-to-isp2 passthrough=no
add action=mark-routing chain=route-client connection-mark=con-from-isp1 new-routing-mark=route-to-isp1 passthrough=no
add action=mark-routing chain=route-client connection-mark=con-from-isp2 new-routing-mark=route-to-isp2 passthrough=no
add action=return chain=route-client disabled=no

/ip firewall mangle
add action=mark-routing chain=output comment=”marking route proxy” connection-mark=con-from-isp1 new-routing-mark=route-to-isp1 out-interface=!wlan2 passthrough=no
add action=mark-routing chain=output connection-mark=con-from-isp2 new-routing-mark=route-to-isp2 out-interface=!wlan2 passthrough=no



Pengaturan Routing
Pengaturan mangle diatas tidak akan berguna jika anda belum membuat routing berdasar mark-route yang sudah kita buat. Disini kita juga akan membuat routing backup, sehingga apabila sebuah gateway terputus, maka semua koneksi akan melewati gateway yang masing terhubung

/ip route
add check-gateway=ping dst-address=0.0.0.0/0 gateway=192.168.101.1 routing-mark=route-to-isp1 distance=1
add check-gateway=ping dst-address=0.0.0.0/0 gateway=192.168.102.1 routing-mark=route-to-isp1 distance=2
add check-gateway=ping dst-address=0.0.0.0/0 gateway=192.168.102.1 routing-mark=route-to-isp2 distance=1
add check-gateway=ping dst-address=0.0.0.0/0 gateway=192.168.101.1 routing-mark=route-to-isp2 distance=2
Pengujian
Dari hasil pengujian kami, didapatkan sebagai berikut
Dari gambar terlihat, bahwa hanya dengan melakukan 1 file download (1 koneksi), kita hanya mendapatkan speed 56kBps (448kbps) karena pada saat itu melewati gateway ISP1, sedangkan jika kita mendownload file (membuka koneksi baru) lagi pada web lain, akan mendapatkan 30kBps (240kbps). Dari pengujian ini terlihat dapat disimpulkan bahwa
512kbps + 256kbps ≠ 768kbps

Catatan :
* Loadbalancing menggunakan teknik pcc ini akan berjalan efektif dan mendekati seimbang jika semakin banyak koneksi (dari client) yang terjadi.
* Gunakan ISP yang memiliki bandwith FIX bukan Share untuk mendapatkan hasil yang lebih optimal.
* Load Balance menggunakan PCC ini bukan selamanya dan sepenuhnya sebuah solusi yang pasti berhasil baik di semua jenis network, karena proses penyeimbangan dari traffic adalah berdasarkan logika probabilitas.
  
Demikianlah Tutorial Cara Setting Load Balancing Mikrotik menggunakan Metode PPC yang diambil dari web Mikrotik.co.id. Selamat mencoba dan Semoga bermanfaat :)

Sumber :

10 October 2013

Cara Me-Repair Database MySQL Error

Bonjour! Pernahkah anda mengalami pengalaman yang mirip dengan saya? Kejadian ini terjadi pada server social site dikantor saya. Social blog site dikantor saya menggunakan wordpress, suatu ketika database di server tersebut mengalami error sehingga ketika dikunjungi terdapat error page "Error established database". Sebenarnya kejadian seperti ini mungkin saja terjadi pada server apapun, ketika traffic ke database terlalu tinggi dan resource server tersebut kurang mendukung maka service mysql di server tesebut hang.

Jika anda mengalami hal tersebut, anda bisa cek setinggi apa traffic ke database server anda dengan mengetikkan perintah dibawah ini :

mysql> show processlist;
+-------+------------+-----------+------------+---------+------+-------+------------------+
| Id    | User       | Host      | db         | Command | Time | State | Info             |
+-------+------------+-----------+------------+---------+------+-------+------------------+
| 87222 | masterdata | localhost | masterdata | Sleep   |    6 |       | NULL             |
| 87229 | masterdata | localhost | masterdata | Sleep   |   18 |       | NULL             |
| 87242 | masterdata | localhost | masterdata | Sleep   |   26 |       | NULL             |
| 87244 | masterdata | localhost | masterdata | Sleep   |   94 |       | NULL             |
| 87262 | masterdata | localhost | masterdata | Sleep   |   29 |       | NULL             |
| 87264 | masterdata | localhost | masterdata | Sleep   |   60 |       | NULL             |
| 87269 | masterdata | localhost | masterdata | Sleep   |    2 |       | NULL             |
| 87272 | masterdata | localhost | masterdata | Sleep   |    2 |       | NULL             |
| 87277 | masterdata | localhost | masterdata | Sleep   |  107 |       | NULL             |
| 87281 | masterdata | localhost | masterdata | Sleep   |   27 |       | NULL             |
| 87291 | root       | localhost | NULL       | Query   |    0 | NULL  | show processlist |
+-------+------------+-----------+------------+---------+------+-------+------------------+
11 rows in set (0.00 sec)

Contoh diatas tidak menunjukkan kondisi service mysql error, tapi jika service pada server anda mengalami hang karena traffic database yang sangat tinggi, saya yakin akan sangat banyak sekali yang keluar ketika anda melakukan query show processlist;

bahkan ketika anda melihat system monitor di server linux anda dengan htop atau top misalnya, service mysql akan tampak memakan resource paling banyak, kondisi di depan website tentu hanya ada warning error established database.

Maka dari itu cara me-repair database mysql error. Untuk melakukannya silahkan lakukan perintah ini :
mysqlcheck -c blog -u root -p
Jika anda ingin menampilkan hasil tersebut kedalam sebuah file tambahkan perintahnya jadi seperti ini :
mysqlcheck -c blog -u root -p > output
Perintah diatas hanya akan memeriksa error database mysql terjadi pada tabel yang mana. Cara me-repair database mysql error secara otomatis silahkan lakukan perintah ini :
mysqlcheck -c blog --auto-repair -u root -p > output
Perintah diatas akan melakukan pemeriksaan pada setiap tabel database di server anda, lalu akan me-repair error table database secara otomatis, dan terakhir melakukan print dari kegiatan tersebut kedalam sebuah file. Dengan begitu anda bisa melihat table mana yang sering mengalami error, dan dapat mengantisipasinya secepat mungkin.

Baiklah, sekian cerita pengalaman saya, cara me-repair database mysql error ternyata tidak terlalu sulit bukan? :)

Semoga bermanfaat,
Salam Penguin! :)



09 October 2013

Cara Mengganti Text Di Dalam File Via Terminal Linux

Bonjour! Saya punya pengalaman baru beberapa hari kebelakang ini, sepertinya pengalaman saya akan berguna bagi anda. Meskipun mungkin dengan kasus yang berbeda namun metode ini sepertinya akan dapat diterapkan ketika anda menghadapi kasus lain dan membutuhkan penyelesaian ini. Saya akan sedikit bercerita tentang kasus saya, dan bagaimana menyelesaikannya. Selamat membaca :)

Kantor saya adalah sebuah perguruan tinggi di Bandung, dinaungi oleh sebuah yayasan pendidikan yang juga memiliki lembaga-lembaga pendidikan lain. Nah, kemaren itu yayasan ini menyatukan semua lembaga menjadi kesatuan universitas. Dampaknya pada IT cukup banyak, karena setiap lembaga berubah nama. Dengan perubahan nama seperti itu otomatis domain internet pun berubah. Singkat cerita, sayapun mulai menyingkilkan lengan baju dan melakukan migrasi domain, semuanya berjalan lancar sampai dengan selesai!

Tapi ada salah satu website blogging yang merupakan multisite blogging. Didalamnya ada ribuan user dan ribuan artikel. Migrasi domain DNS saja tidak cukup, karena URL SETIAP BLOGURL SETIAP ARTIKEL, URL SETIAP GAMBAR semuanya tertanam didalam database. Cukup menantang, dimana saya harus segera merubah semua url sialan tersebut ke url dengan domain baru. Saya yakin andapun tidak akan mau jika harus merubah semua itu secara manual, satu per satu, kapan selesainya? :|

Bagaimana cara mengganti text di dalam file tersebut via terminal linux? Setelah mencari cara dan melakukan beberapa percobaan akhirnya semua itu dapat diatasi bahkan jika saya melakukannya dari awal secara benar, itu hanya memakan hitungan menit.

Multisite ini adalah wordpress social blogging yang dibuat untuk menampung semua tulisan seluruh civitas, untuk site setting dan konfigurasi script tidak terlalu sulit. Anda bisa mencarinya dengan mudah di mbah google. Saya hanya akan fokus menyampaikan bagaimana mengganti semua url tadi menjadi url dengan domain baru. Berikut ini langkah-langkahnya :
  • DUMP database anda. Ya, backup terlebih dahulu database anda. File backup yang saya miliki cukup besar untuk sebuah database, ratusan MB lah.
  • Selanjutnya, anda tidak perlu membuka file dump tersebut karena sangat menjengkelkan dan bikin mumet. Cukup ketikkan perintah dibawah ini pada server linux anda :
    root@apocalypsix: sed -e 's/[text_yang_mau_diganti]/[text_yang_baru]/g' [nama_file] > [output_file]
  • Langkah terakhir adalah meng-import kembali file output.
  • Selesai!

PENJELASAN :

Perintah diatas akan mencari sebuah text dan menggantinya dengan yang baru, pengerjaannya sangat cepat. Berbeda dengan jika saya melakukannya dengan nano editor, memakai notepad++ pun tidak membantu banyak, masih terdapat missing line yang tidak di eksekusi. Saya berikan contoh lain, misalnya kita memiliki sebuah file bernama daftar_gaji yang didalamnya ada banyak text. Misalnya isinya seperti ini :
Daftar gaji berdasarkan pendidikan :
SD  = 500.000
SMP = 700.000
SMA = 1.300.000
D3  = 1.500.000
S1  = 2.000.000
Misalnya kita harus merubah gaji bagi yang berlulusan SD, dari 500.000 menjadi 600.000. Untuk mengganti text di dalam file via terminal linux, lakukan perintah seperti tadi :
root@apocalypsix : sed -e 's/500.000/600.000/g' daftar_gaji > daftar_gaji_baru
Kira-kira seperti itulah, kasus saya pun terselesaikan hanya dengan sepenggal sajak berbahasa linux :D
Jika anda juga mengalami kasus serupa dan bingung bagaimana cara mengganti text di dalam file via terminal linux, mungkin cara ini bisa anda pakai, sepertinya format linux dan unix pun tidak akan terlalu jauh berbeda.


Semoga bermanfaat,
Salam Penguin! :)



07 October 2013

Installasi Dan Konfigurasi DNS Di Linux (BIND) - Part 3

Bonjour! Kita bertemu lagi di blog Tutorial Linux Berbahasa Indonesia, mungkin ini adalah postingan terakhir untuk topik kita mengenai DNS. Jika anda belum membaca artikel bersambung ini sebelumnya, saya sarankan untuk membacanya terlebih dahulu sebelum mempelajari lebih dalam lagi. Artikel sebelumnya ada di link dibawah ini :



Zona
Direktif zone untuk mendefinisikan domain yang akan dilayani oleh BIND. Dalam contoh kasus kita, zona yang akan ditangani oleh bind adalah domain apocalypsix.web.id. Direktif zone dapat berisikan direktif lain dan dideklarasikan diantara tanda kurung kurawal awal { dan ditutup dengan kurung kurawal } didalam direktif zone.

Penulisan opsi lain didalam opsi zone diakhiri dengan tanda titik koma ( ; ), termasuk opsi zone sendiri yang diakhiri dengan tanda titik koma ( ; ). Berikut adalah deklarasi untuk domain apocalypsix.web.id yang terdapat di berkas named.conf.local.

zone "apocalypsix.web.id" {
   type master;
   file "/etc/bind/apocalypsix.web.id";
};

Contoh diatas merupakan contoh konfigurasi minimal untuk sebuah domain yang hanya berisikan direktif type dan file. Direktif type akan menentukan sifat dari zona apakah bertindak sebagai master atau slave. Opsi ini akan dibahas lebih jauh di bagian server redundan sedangkan direktif file memberitahukan BIND lokasi dari berkas konfigurasi zona apocalypsix.web.id yang dapat ditemukan di /etc/bind/apocalypsix.web.id. Selain kedua direktif tersebut ada beberapa direktif lain yang akan berada didalam direktif zone. Daftar berikut adalah direktif yang dapat berada didalam direktif zone.

also notify { daftar-alamat; }; Digunakan untuk memberitahukan server DNS lain (Server DNS Slave) ketika terjadi perubahan catatan zona.

allow notify { daftar-alamat; }; Digunakan di Server DNS Slave untuk mengijinkan pemberitahuan perubahan catatan DNS yang berasal dari server master.

master { daftar-alamat; }; Digunakan oleh Server DNS Slave untuk mendefinisikan Server DNS Master.

allow query { daftar-alamat; }; Digunakan untuk mendefinisikan siapa yang diijinkan untuk melakukan permintaan ke Server DNS. Direktif ini digunakan untuk membatasi akses terhadap DNS, sehingga hanya klien yang telah ditentukan saja yang dapat melakukan permintaan ke server DNS.

allow-transfer { daftar-alamat; }; Digunakan oleh server DNS master untuk mengijinkan transfer berkas zona ke server DNS slave.

notify-source alamat-IP port alamat-port; Digunakan untuk secara eksplisit menentukan alamat IP dan port yang digunakan untuk memberitahukan server lain perubahan catatan zona.


View
Direktif view dan zone merupakan dua direktif yang saling berhubungan. Direktif ini baru diperkenalkan di BIND versi 9. Direktif view bertindak sebagai kontainer untuk direktif zone yang menyebabkan BIND akan memberikan jawaban yang berbeda untuk permintaan yang masuk tergantung darimana permintaan tersebut berasal.

Sebagai contoh, jika ada permintaan DNS terhadap host www.apocalypsix.web.id maka BIND dapat dikonfigurasi untuk membverikan jawaban yang berbeda. Jika permintaan berasal dari internet, maka BIND akan memberikan jawaban alamat IP publik sedangkan permintaan dari dalam jaringan lokal akan diberikan jawaban IP lokal. Metode ini lebih dikenal dengan nama split DNS.

Manfaat lain view adalah memisahkan fungsi otoritatif dan cache DNS. Sebaiknya fungsi cache hanya diperuntukan untuk jaringan lokal dan menutupnya dari internet demi alasan keamanan.


Berkas Zona
Setelah suatu domain telah di deklarasikan di dalam berkas named.conf.local maka langkah selanjutnya yang perlu dilakukan adalah membuat berkas zona itu sendiri. Nama dan lokasi berkas harus sesuai dengan direktif file yang dideklarasikan didalam direktif zone. Dalam kasus zona apocalypsix.web.id, nama berkas zona tersebut adalah apocalypsix.web.id yang terletak di direktori /etc/bind.

Berkas zona sebenarnya merupakan berkas yang berisikan daftar nama host yang ada didalam suatu domain. Berkas ini mempunyai fungsi utama untuk memetakan nama host dengan alamat IP selain berisikan beberapa direktif atau opsi lain yang berkaitan dengan suatu zona.

Untuk membuat berkas zona, ada baiknya jika kita melakukan pendataan terlebih dahulu atau semua host yang berada di dalam domain kita. Hal ini tentu saja untuk memudahkan kita dalam mengelola dan membagikan alamat IP ke server, dan juga mengelola penamaan host di domain.

Berkas zona memiliki format penulisan tertentu yang harus diikuti. Sebagai contoh berikut adalah berkas zona untuk domain apoclaypsix.web.id.

; BIND reverse data file for broadcast zone

$ORIGIN apocalypsix.web.id.
$TTL 1d

@   IN SOAns.apocalypsix.web.id. hostmaster.apocalypsix.web.id {
    906030942    : Serial number
    86400        ; Refresh
    1800         ; Retry
    50400        ; Expire
    3600         ; Negative cache TTL
};
    IN      NX        ns.apocalypsix.web.id.
    IN      MX   10   mail.apocalypsix.web.id.

ns       IN    A   10.10.1.1
proxy    IN    A   10.10.1.1
www      IN    A   10.10.1.1
mail     IN    A   10.10.1.5
ntp      IN    A   10.10.1.7

Semua berkas zona memiliki format dasar seperti diatas. Diawali dengan parameter yang ditujukan untuk zona tersebut, direktif khusus yang disebut sebagai rekaman (record) dimana setiap berkas zona diawali dengan rekaman SOA dan dilanjutkan dengan rekaman lainnya. Berbeda dengan berkas konfigurasi untuk aplikasi lainnya, komentar di berkas zona ditandai dengna tanda ; (titik koma) atau //.

Parameter digunakan di BIND biasanya digunakan untuk memberitahukan BIND mengenai informasi tertentu. Nilai yang diisikan kedalam parameter tersebut akan digunakan oleh BIND, namun bila tidak dideklarasikan maka adalah beberapa parameter yang sering digunakan.

$INCLUDE Parameter ini akan memasukkan berkas yang lain kedalam berkas zona tepat pada tempat dimana opsi ini digunakan. Hal ini berguna jika kita ingin menggunakan berkas lain untuk memisahkan konfigurasi zona terspisah dari berkas zona utama.

$ORIGIN Parameter ini akan menambahkan nama domain ke nama host relatif. Setiap nama host yang tidak diakhiri dengan tanda titik (.) merupakan nama host relatif dan akan ditambahkan nama domain sesuai dengan nama domain yang ditentukan oleh parameter ini.

05 October 2013

Installasi Dan Konfigurasi DNS Di Linux (BIND) - Part 2

Bonjour! Kita bertemu lagi di blog Tutorial Linux Ubuntu Berbahasa Indonesia. Sebelumnya saya sudah sedikit mengulas mengenai beberapa konfigurasi bind di linux. Jika anda belum membacanya, silahkan klik link dibawah ini.
Sekarang mari kita lanjutkan pembahasan sebelumnya. Kali ini saya akan membahas mengenai logging bind.

Logging
Bind memiliki fasilitas log yang cukup fleksibel menurut saya karena dapat dikonfigurasi sesuai dengan kebutuhan yang dikontrol oleh direktif logging. Bind versi 9 memiliki kemampuan kontrol yang sama dengan bind versi sebelumnya, namun memiliki fasilitas tambahan yang tidak dimiliki oleh bind versi 4, terutama dalam hal kemampuan mengontrol fasilitas log.

Ada dua konsep yang harus dipahami untuk sistem log bind sebelum kita dapat mengkonfigurasi bind secara efektif, yaitu saluran (channel) dan kategori. Channel merupakan istilah yang digunakan oleh bind untuk mengatur kemana data log tersebut pergi, ke sistem syslog, ke berkas,ke stderr, atau dibuang. Kategori digunakan untuk mendefinisikan data apa yang masuk ke log, dan bind memiliki sejumlah kategori yang dibangun ke dalam kode sumber bind.

Sama seperti sistem log di linux, bind juga memiliki tingkat ataupun level log yang dapat digunakan untuk mem-filter pesan log sehingga secara selektif hanya pesan log dengan level tertentu saja dapat masuk ke dalam log. Level tersebut mulai dari ringan sampai terberat berturut-turut dynamic, debug, info, notice, warning, error, dan critical.

Setiap kategori data yang dideklarasikan, dapat disalurkan ke satu ataupun beberapa saluran secara bersamaan. Sebagai contoh kita akan membuat sistem log sebagai berikut :

     kategori keamanan   ----> channel log
                         ----> channel berkas
     kategori permintaan ----> channel berkas

Kita akan membuat tiga buah channel, yaitu satu channel untuk ke syslog dan 2 channel ke berkas yang akan diberi nama my_syslog, my_query dan my_sec. Channel my_syslog akan menampung log dengan level minimal info, sedangkan my_query dan my_sec dengan level minimal dynamic. Kategori yang akan digunakan adalah tiga, yaitu kategori default, security dan queries.

Data log untuk kategori default akan dibuang, sedangkan data log untuk kategori security akan dilewatkan ke syslog dan juga disimpan ke berkas sec_log. Sedangkan data kategori queries akan disimpan ke berkas query.log. Berikut ini adalah konfigurasi tersebut.

logging {
    channel my_syslog {
       syslog daemon;
       severity info;
  };

     channel my_query {
       file "/var/log/bind/query.log";
       severity dynamic;
  };

     channel my_sec {
       file "/var/log/bind/sec.log";
       severity dynamic;
  };
   category default { null; };
   category security { my_syslog; my_sec };
   category queries { my_query; };
};

Setelah memasukkan konfigurasi diatas restart service bind, lalu kita dapat melihat log untuk kategori query di query.log dan kategori security di sec.log sebagai berikut:

apocalypsix@ns: # tail -f /var/log/bind/query.log
client 10.10.1.1#36887: view internal: query: clients4.google.com IN A +
client 10.10.1.1#45961: view internal: query: ttt.wowowo.com IN A +


Options
Direktif option mengontrol berbagai macam perilaku bind seperti port yang digunakan, forwarder, dan lokasi berbagai berkas konfigurasi. Debian dan Ubuntu menyediakan berkas khusus yang diperuntukan bagi direktif options yaitu named.conf.options. Direktif ini berisikan daftar direktif lain. Secara default, berkas ini berisikan direktif lain sebagai berikut :

options {
  directory "/var/cache/bind";
  auth-nxdomain no;
  listen-on-v6 { any; };
};

Direktif directory merupakan alamat direktori yang digunakan oleh bind untuk menyimpan cache bind. Direktif auth-nxdomain digunakan untuk oleh bind untuk menentukan apakah menjawab NXDOMAIN, atau alamat yang tidak ada. secara otoritatif. Direktif listen-on-v6 digunakan untuk menentukan apakah bind akan menjawab permintaan ipv6.

Selain direktif tersebut, ada berbagai macam direktif yang dapat digunakan di direktif options. Berikut ini adalah daftar direktif yang sering digunakan di direktif options.

  • query-source address * port 53, digunakan untuk menentukan port yang digunakan oleh bind untuk mengajukan permintaan ke server lain.
  • forwards { alamat-ip; }; digunakan oleh bind untuk meneruskan permintaan hanya ke server yang ditentukan di alamat.ip.
  • recursion yes|no digunakan untuk menentukan apakah bind akan menjawab permintaan secara rekursif atau tidak.
Baiklah, saya mengantuk sekali sekarang. Saya cukupkan dulu sekian artikel ini, besok atau lusa kalau sempat akan saya teruskan, sekaligus menutup pembahasan mengenai installasi dan konfigurasi dns di linux menggunakan bind. Semoga artikel ini memberikan manfaat kepada anda.

Salam penguin! :)


Install/Upgrade Kernel 3.11.3 di Ubuntu 12.04 LTS

Akhirnya kernel Linux terbaru rilis juga. Kini sudah sampai ke versi 3.11.3. Wah, ini pasti menjadi kabar yang sangat menggembirakan bagi para pecinta kernel 3.11.

Kernel 3.11.3 ini membawa banyak perbaikan bug dan juga memiliki support driver yang lebih banyak. Selain itu juga ada banyak perubahan-perubahan terbaru lainnya. Untuk lebih lengkapnya, Kalian bisa membaca pernyataan rilis resminya di halaman web ini.

Yuk, langsung saja kita install/upgrade kernel 3.11.3 di Ubuntu. Disini saya menggunakan Ubuntu 12.04 sebagai bahan percobaannya.

1. Bukalah terminal kalian (CTRL + ALT + T) lalu ketikkan perintah berikut ini untuk mendownload file DEB yang diperlukan :

Untuk 32 Bit


$ wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.11.3-saucy/linux-headers-3.11.3-031103-generic_3.11.3-031103.201310011421_i386.deb
$ wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.11.3-saucy/linux-headers-3.11.3-031103_3.11.3-031103.201310011421_all.deb
$ wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.11.3-saucy/linux-image-3.11.3-031103-generic_3.11.3-031103.201310011421_i386.deb


Untuk 64 Bit

$ wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.11.3-saucy/linux-headers-3.11.3-031103-generic_3.11.3-031103.201310011421_amd64.deb
$ wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.11.3-saucy/linux-headers-3.11.3-031103_3.11.3-031103.201310011421_all.deb
$ wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.11.3-saucy/linux-image-3.11.3-031103-generic_3.11.3-031103.201310011421_amd64.deb



2. Setelah ketiga file itu sudah terdownload, langsung jalankan perintah ini untuk menginstallnya :

$ sudo dpkg -i linux-headers-3.11.3*.deb linux-image-3.11.3*.deb

3. Restart komputer kalian.

Semoga bermanfaat :)

SUMBER

04 October 2013

Membersihkan Memory Yang Tidak Terpakai di Ubuntu

Oh my god, kenapa tiba-tiba performa komputer ini menurun? Perasaan sebelumnya berjalan lancar jaya tidak ada kendala.

Penurunan performa komputer bisa memiliki beberapa faktor penyebabnya, mulai dari space hardisk yang minim, banyaknya aplikasi yang berjalan dan jumlah RAM minim.

Untuk mengatasinya tentu kita bisa upgrade hardware, hardsik, memory maupun memory yang lebih besar dan cepat.

Tapi itu bukan satu satunya cara, karena kita bisa juga memaksimalkan memory kita dengan cara membersihkannya ketika tidak dipakai oleh sistem.

Tutorial ini seperti biasa saya menggunakan Ubuntu 13.04, untuk melakukan pekerjaan yang berhubungan dengan memory, kita bisa menggunakan perintah berikut :

Mengecek Pemakaian Memory
  • watch -n 1 free -m atau
  • watch -n 1 cat /proc/meminfo

Membebaskan Memory Yang Tidak Terpakai :
  • sudo sysctl -w vm.drop_caches=3 atau
  • sudo sync && echo 3 | sudo tee /proc/sys/vm/drop_caches

Semoga bisa membantu :)

Cara Melakukan Screenshot di Ubuntu

Hello, kali ini saya coba untuk sedikit ngasih bocoran nih :) tentang cara mengambil screenshot / capture layar di Ubuntu.

Kita bisa menggunakan aplikasi Screenshot (Ubuntu) atau dengan KSnapshot (Kubuntu) dan juga aplikasi-aplikasi lainnya.

Pastinya hal ini tidak asing kalau kita sudah terbiasa bekerja dengan Ubuntu Desktop, jadi bagi yang udah familiar dengannya barangkali postingan ini tidak perlu-perlu amat ya? :)

Sebenarnya postingan ini lebih pas untuk yang baru saja kenal atau menggunakan ubuntu desktop sebagai lingkungan kerjanya dan memerlukan tampilan layar atau bagian tertentu dari layar desktop kita. Untuk apapun itu gak harus dipertanyakan. Betul? :)

Lalu bagaimana caranya kita melakukan screenshot di ubuntu? Begini caranya :

Buka sebuah aplikasi Screenshot, dari dash ubuntu cukup kita ketikkan screenshot. Setelah terbuka disana ada beberapa opsi yang bisa kita sesuaikan dengan keperluan kita dan terbagi menjadi :
  1. Grab the whole desktop, adalah opsi yang bisa kita gunakan bila ingin mengambil seluruh tampilan desktop.
  2. Grab the current window, adalah opsi yang tepat bila kita hanya ingin meng-capture jendela atau windows yang sedang aktive.
  3. Select area to grab, adalah opsi yang bisa kita gunakan ketika kita hanya ingin mengambil bagian tertentu dari layar monitor kita
Selain itu, disana ada opsi untuk mengatur delay capture ketika kita meng-klik Take Screenshot dan aksi capturing oleh Screenshot ini.

Save Screenshot
Pilihan selanjutnya (lihat Save Screenshot) adalah :

Kita segera memberikan nama file sebelum Screenshot menyelesaikan tugasnya.
  1. Tentukan lokasi dimana kita akan menyimpan file hasil screenshot.
  2. Selain menyimpannya dalam bentuk file, kita juga bisa meng-kopy-nya ke memory sistem yang bisa kita gunakan untuk keperluan lain, misalnya kita bikin file baru dengan gimp melalui menu File - Create from clipboard

Demikian sedikit curhat atau cuap-cuap ini yang penting gak penting yang penting exist :)

Apapun jawabannya, semoga ini bisa bermanfaat :)



03 October 2013

Cara Install OpenERP di Ubuntu

OpenERP adalah salah satu program ERP atau biasa disebut Entreprise Resource Planing, seperti SAS atau Oracle ERP. Nah karena program closed source itu sangat mahal bisa milyaran atau bahkan triliunan, nah aplikasi open source memberi alternatif yang lain. nah langsung saja kita install OpenERP, berikut langkahnya :






1. Install Postgresql


 sudo apt-get install postgresql


2. lalu install

01 October 2013

Websharing, Transfer File Dari Device Android Ke PC Semakin Mudah


Seringkali kita merasa malas ataupun lupa untuk membawa kabel data USB ketika kita sedang bepergian, padahal ada saat dimana kita membutuhkan kabel data untuk transfer file dari device Android kita ke PC. Tenang, karena aplikasi bernama Websharing, yang dapat berfungsi sebagai sarana untuk transfer file secara nirkabel, yang kita butuhkan adalah jaringan WiFi, PC/Laptop yang terhubung di jaringan tersebut, dan tentu saja aplikasi Websharing yang telah kita install pada device Android kita.

Kita akan sedikit membahas apa itu Websharing, Websharing adalah aplikasi buatan Tod Lieback. Websharing yang saat penulis menulis artikel ini sudah berada pada versi 2.0.0.b9 Beta. Websharing terdiri dari 2 versi utama, yaitu versi bayar dan versi Lite alias gratis. Pada versi berbayar mempunyai fitur untuk Music Player, Video Player, dan lain-lain. Untuk versi Lite, hanya akan mendapat File Explorernya saja.

Untuk mendapatkan Websharing versi Beta (terbaru) harus melalui beberapa step, karena sesuai regulasi google untuk aplikasi yang memiliki versi beta, diperkenankan untuk menjadikan user sebagai Beta Tester. Untuk mendapatkan versi non-beta, bisa langsung diunduh disini.

Step By Step untuk mendapatkan versi paling update (Beta) :
  1. Join Komunitas Websharing Beta Testing-nya disini
  2. Masuk ke halaman aplikasi beta tester di google playsore. Lite & Paid Version
  3. Setelah selesai, silahkan download aplikasinya, maka yang terinstall adalah yang versi Beta.
  4. Jika tidak ingin dipusingkan dengan step-step diatas, dapat langsung download file .apk nya disini

Untuk memakai Websharing :
  1. Koneksikan PC/Laptop dan device Android kamu ke jaringan internet / WiFi yang sama
  2. Hidupkan aplikasi Websharing di device Android kamu
  3. Akan ada perintah untuk masuk ke alamat tertentu dan menuliskan passworddi browser PC/Laptop (contoh: http://192.168.1.136:2112/ Password: d4j68)
  4. Tulis Alamat yang muncul di aplikasi Websharing di browser PC/Laptop dan tuliskan Password-nya
  5. Aplikasi siap digunakan.


 Selamat Mencoba.