28 February 2014

Gejala PC Karena Faktor X

Cara mengetahui gejala yang timbul karena human error atau computer sendiri yang error:


  1. apabila mengoprek komputer PC tanpa mematikan PC tersebut, kadang-kadang secara tidak sadar menyenggol atau membuat korsleting PC sehingga restart sendiri atau malahan mati total tanpa bisa menyalakannya lagi,. lebih baik gunakan dengan cara mencopot baterai BIOS, lalu pasang lagi. ataupun jika ada sistem pin jumper, silahkan tukar pin selama beberapa detik lalu kembalikan ke semula jumper tersebut. setelah itu silahkan nyalakan PC kembali, mudah-mudahan bisa hidup. kalaupun tidak hidup, silahkan bawa ke tempat service.
  2. apabila tiba-tiba PC muncul BLUE SCREEN ketika komputer berjalan,. lebih baik cek RAM (memory) apakah kapasitas dalam program sebanding dengan kapasitas RAM tersebut. silahkan cek melalui task manager. jika ternyata saat BLUE SCREEN muncul lalu kita mematikan PC secara paksa (tekan tombol power selama 5 detik) lalu tidak bisa restart, lebih baik gunakan cara 1. lalu masuk safe mode. cari letak masalahnya .

Cara Membuat Installshield Express



Dalam pembuatan installshield pertama kali yang harus dilakukan adalah masuk ke dalam program installshield yang anda punya dan akan tampil gambar di samping. lalu klik create a new project - blank setup project - create





Membuat Web Hosting 000WEBHOST

Earn Money - Join Affiliate Program!

Do not miss a chance to earn money!
Send visitors to our website and for each registration we will pay you $5!
Payment will be sent by check, wire transfer or PayPal as soon you will accumulate $100 (or 20 signups) every month.


We have everything you may need:
  • Over 40 banners
    Our banners are eye catching with high clickthrough rate. Just copy/paste a given HTML code of banner and insert in to your webpage - signups are guaranteed.

25 February 2014

Instalasi Squid Lusca Proxy di Ubuntu Server 12.04 LTS


Ada beberapa artikel yang pernah saya baca yang membahas tentang cara instalasi Squid Lusca di Ubuntu, baik itu untuk versi 12.04 maupun untuk versi Ubuntu sebelum-sebelumnya. Tapi dari beberapa artikel tersebut, kebanyakan kurang jelas step by step instalasinya. Ada juga yang kurang mantap performanya, bahkan ada yang tidak bisa HIT sama sekali!

Satu-satunya tutorial yang membahas secara gamblang dan lengkap sekali petunjuk step by stepnya hanyalah di trit yang ada di forum Ubuntu-indonesia.com ini. Oleh karena itu, berdasarkan sumber dari trit tersebut, saya akan mencoba menuliskannya kembali disini dengan step by step yang insyaAllah lebih saya perjelas lagi. Tujuannya tentu agar semua orang bisa mencoba membuat Squid Lusca ini dengan mudah dan benar. :)

Yang Harus Disiapkan
  1. Memiliki pengetahuan dasar tentang jaringan dan Linux. Setidaknya kalian sudah harus paham betul konsep jaringan TCP/IP seperti ip address, subnet mask, dll. Selain itu kalian juga harus sudah paham cara pengkonfigurasian jaringan di Ubuntu, seperti mengganti ip address, gateway, dan dns. Silahkan download ebook saya disini untuk pembahasan mengenai cara-cara konfigurasi jaringan dasar di Ubuntu Server 12.04 LTS.
  2. Memiliki pengetahuan tentang perintah-perintah dasar di Linux, seperti cp, mv, mkdir, chown, chmod, dan vim atau nano. Bisa kalian cari di google ebook-ebook yang membahas mengenai perintah dasar terminal di Linux.
  3. Memiliki pengetahuan tentang cara instalasi Ubuntu Server 12.04 LTS. Silahkan download ebook saya disini untuk pembahasan mengenai cara instalasi Ubuntu Server 12.04 LTS.
  4. Memiliki Harddisk paling minimal 2 buah. Karena wajib hukumnya untuk memisahkan antara harddisk untuk sistem dan harddisk untuk penyimpanan cache. Tujuannya agar performa si Squid bisa mencapai kemampuan tertinggi. 
  5. 1 buah kartu jaringan. Boleh menggunakan kartu jaringan yang onboard kok.

Spesifikasi Komputer Saya

Spek komputer berikut merupakan spek komputer yang saya gunakan di Virtualbox untuk keperluan praktek pembuatan Proxy pada artikel ini. Konsepnya sama saja, silahkan disesuaikan dengan spesifikasi komputer yang kalian punya.

1. Processor : Intel Core i3
2. Ram : 2 GB
3. HDD :
  • HDD1 : 8 GB --> Untuk sistem
  • HDD 2 : 20 GB --> Untuk penyimpanan cache
4. 1 buah kartu jaringan onboard.

Instalasi Ubuntu Server 12.04 LTS dan Pemartisian

Proses instalasi Ubuntu Server 12.04 LTS untuk keperluan Proxy server notabene sama saja dengan cara instalasi Ubuntu Server yang saya tulis di ebook saya. Jadi silahkan kalian ikuti saja step-by-step yang ada disitu. Letak perbedaannya hanya terdapat pada bagian pemartisian harddisk. Kalau di ebook saya menggunakan metode Guided, maka khusus untuk pembuatan Proxy, kita harus mempartisi Harddisk kita secara manual. Berikut adalah langkah-langkahnya :

1. Saat muncul bagian Partition Method, pilih Manual.


2. Kemudian akan terlihat ada dua buah harddisk disitu beserta ukurannya. HDD1 yang berukuran 8 GB akan saya bagi untuk Swap Area sebesar 2GB dan sisanya untuk sistem /. Ukuran Swap Area idealnya adalah 2x RAM. Namun apabila RAM kalian sudah 2GB keatas, maka sebaiknya ukuran Swap Area kalian buat sebesar 2GB saja. Karena nanti mubazir si Swap Areanya jarang terpakai sebab ukuran RAM kalian sudah cukup besar. 

Tekan Enter pada HDD1. Apabila Harddisk kalian adalah Harddisk baru, maka ketika kalian tekan Enter, akan muncul pertanyaan seperti berikut. Pilih Yes.


Setelah itu akan terlihat Free Space dari HDD1. Tekan Enter pada Free Space tersebut.


Pilih Create New Partition.


Ketikkan ukuran partisi yang ingin kalian buat. Karena disini saya ingin membuat Swap Area terlebih dahulu, maka ketik saja 2 GB. Lalu tekan Enter.


Untuk tipe partisinya, pilih saja Primary.


Pilih Beginning apabila muncul pertanyaan seperti ini.


Ganti bagian Use As menjadi Swap Area. Jika sudah pilih Done Setting Up New Partition.


Lakukan hal yang sama untuk membuat partisi /. Bedanya adalah pada bagian Partition Settings, kalian pilih Use As : Ext4 journaling file system, dan Mount point : /. Jika sudah pilih Done Setting Up New Partition.

Untuk harddisk yang kedua pun caranya sama seperti diatas. Perbedaannya pada bagian Partition Settings, kalian pilih Use As : ReiserFS journaling file system, Mount point > Enter Manually > /proxy. Jika sudah pilih Done Setting Up New Partition.


Jika kalian melakukannya dengan benar, maka tampilannya kira-kira akan seperti berikut. Setelah itu tekan Enter pada Finish partitioning and write changes to disk.


Terakhir pilih Yes.


Instalasi Squid Lusca

1. Pertama-tama pastikan bahwa si Proxy kalian ini sudah bisa terkoneksi ke internet. Silahkan diatur saja settingan gateway dan dns sesuai dengan skema jaringan milik kalian. Kalau topologi jaringan saya adalah sebagai berikut :

internet --------------------------------(10.0.0.2)mikrotik(192.168.1.1)--(192.168.1.2-192.168.1.100) client
(192.168.0.1)
|
|
(192.168.0.2)
 proxy

2. Aktifkan user root agar nanti tidak terlalu ribet menggunakan sudo di setiap perintah yang kalian lakukan. Langkah ini sebenarnya opsional saja, karena walaupun tidak mengaktifkan user root, kalian masih bisa melakukan semua langkah-langkah instalasi Squid Lusca-nya.

Untuk mengaktifkan user root silahkan eksekusi perintah berikut :

$ sudo -i
# passwd

Lalu masukkan password baru untuk user root.

3. Langkah kedua, kalian perlu menaikkan jumlah maksimal file descriptor yang bisa dibaca oleh sistem. Ini sangat diperlukan apabila ukuran cache kalian sudah diatas 100GB, karena semakin besar ukuran cache, maka semakin besar pula kebutuhan file descriptornya.

Untuk menaikkan file descriptor, eksekusi perintah berikut :

# nano /etc/security/limits.conf

Pada bagian paling bawah file tersebut tambahkan script ini :

root - nofile 65535

Setelah itu restart komputer :

# reboot

Setelah komputer direstart, pastikan bahwa efeknya sudah berjalan :

# ulimit -a | grep 'open files'
open files   (-n) 65535

4. Selanjutnya kita harus menambahkan modul ip_conntrack agar performa squid semakin baik :

# nano /etc/modules

Pada baris paling bawah tambahkan :

ip_conntrack

Simpan jika sudah.

5. Langkah berikutnya adalah menginstall paket-paket yang diperlukan untuk menginstall Lusca :

# apt-get update
# apt-get install apache2 php5 squid squidclient squid-cgi gcc build-essential sharutils ccze libzip-dev automake1.9 libfile-readbackwards-perl -y

6. Setelah itu download juga paket Luscanya :

# wget http://backcode.googlecode.com/files/LUSCA_HEAD-r14809-patch.tar.bz2

7. Setelah proses download selesai, ekstraklah file tersebut :

# tar -xvjf LUSCA_HEAD-r14809-patch.tar.bz2

8. Sekarang baru kita masuk ke dalam tahap pengkompilan. Sebelum itu, kalian harus mengetahui terlebih dahulu kode CFLAGS dari tipe prosesor kalian. Karena kode CFLAGS ini kita perlukan untuk proses pengkompilan.

Ketahui terlebih dahulu tipe prosesor kalian dengan mengetikkan perintah berikut :

# cat /proc/cpuinfo

Perhatikan bagian yang kira-kira ada seperti ininya :

processor : 0
vendor_id : GenuineIntel
cpu family : 6
model : 37
model name : Intel(R) Core(TM) i3 CPU       M 380  @ 2.53GHz

Setelah kalian mengetahui tipe prosesor kalian, baru cari CFLAGS nya dari web ini http://wiki.gentoo.org/wiki/Safe_CFLAGS atau web ini http://gentoo-en.vfose.ru/wiki/Safe_Cflags/Intel#Core_i7_and_Core_i5.2C_Xeon_55xx khusus untuk intel Xeon.



Dari situ kalian bisa dapatkan kode yang kira-kira seperti ini (yang ini merupakan CFLAGS untuk Processor Intel Core i3) :

CHOST="i686-pc-linux-gnu" CFLAGS="-O2 -pipe -march=core2 -msse4 -mcx16 -mpopcnt -msahf -fomit-frame-pointer" CXXFLAGS="${CFLAGS}"

Silahkan kalian kopi, lalu simpan baik-baik. Kode ini akan kita perlukan untuk langkah selanjutnya.

9. Yuk kita mulai proses kompilnya :

# cd LUSCA_HEAD-r14809
# make clean
# CHOST="i686-pc-linux-gnu" CFLAGS="-O2 -pipe -march=core2 -msse4 -mcx16 -mpopcnt -msahf -fomit-frame-pointer" CXXFLAGS="${CFLAGS}" \
./configure -prefix=/usr -exec-prefix=/usr -bindir=/usr/sbin -sbindir=/usr/sbin \
-libexecdir=/usr/lib/squid -sysconfdir=/etc/squid -localstatedir=/var/spool/squid \
-datadir=/usr/share/squid --enable-gnuregex --enable-async-io=24 --with-aufs-threads=24 \
--with-pthreads --with-aio --with-dl --enable-storeio=aufs,null \
--enable-removal-policies=heap --enable-icmp --enable-delay-pools --disable-wccp \
--enable-snmp --enable-cache-digests --enable-default-err-language=English \
--enable-err-languages=English --enable-linux-netfilter --disable-ident-lookups \
--with-maxfd=65535 --enable-follow-x-forwarded-for --enable-large-cache-files \
--with-large-files --enable-referer-log
# make
# make install

nb : pada script yang saya tandai merah, kalian ganti dengan kode CFLAGS milik kalian masing-masing.

Jika tidak ada pesan error, maka sampai tahap ini squid lusca kalian sudah berhasil terinstall.

10. Selanjutnya kalian harus mengganti hak akses partisi penyimpanan cache kalian agar menjadi kepemilikan user proxy dan grup proxy :

# chown -R proxy.proxy /proxy
# chmod -R 777 /proxy

11. Buat juga direktori untuk penyimpanan file log dari si Squid :

# mkdir /var/log/squid

Jangan lupa ganti kepemilikannya menjadi milik user proxy dan grup proxy juga :

# chown -R proxy.proxy /var/log/squid

12. Untuk file-file konfigurasi milik squidnya, saya sudah menyiapkannya untuk kalian. File-file konfigurasi ini saya dapatkan dari trit ubuntu-indonesia.com juga. Silahkan didownload saja :

# wget https://dl.dropboxusercontent.com/u/64064946/fileconfig.tar.gz

13. Ekstrak dan kopikan file-file konfigurasi tersebut ke direktori /etc/squid :

# tar -xvf fileconfig.tar.gz
# cp fileconf/* /etc/squid

14. Beri hak akses eksekusi untuk semua file berekstensi .pl pada direktori /etc/squid :

# chmod 0755 /etc/squid/*.pl

15. Dari semua file-file konfigurasi yang saya berikan hampir semuanya sudah tinggal pakai. Namun apabila kalian ada yang menggunakan konfigurasi yang berbeda dari punya saya, seperti subnet klien, nama disk cache, besar RAM, maupun ukuran harddisk disk cache, maka ada beberapa file yang perlu kalian edit.

Merubah subnet klien

Sesuai dengan topologi jaringan saya berikan diatas, subnet untuk klien saya adalah 192.168.1.0/24. Jika kalian ingin merubahnya sehubungan dengan perbedaan topologi jaringan, maka edit file acl.conf :

# nano /etc/squid/acl.conf

Cari baris acl localnet src 192.168.1.0/24 (Gunakan fasilitas search dengan menekan tombol CTRL + W). Lalu ganti bagian 192.168.1.0/24 sesuai dengan yang kalian inginkan. Jika sudah simpan dan tutup file tersebut.

Merubah nama disk cache

Pada artikel ini, disk cache yang saya buat bernama /proxy. Apabila kalian menggunakan nama lain, silahkan edit file squid.conf :

# nano /etc/squid/squid.conf

Cari bagian cache_dir aufs /proxy 16000 37 256 , lalu ganti bagian /proxy menjadi nama disk cache sesuai dengan milik kalian masing-masing.

Mengubah ukuran disk cache

Ukuran harddisk untuk disk cache pada artikel ini adalah sebesar 20GB. Untuk mengubahnya sesuai dengan ukuran disk cache kalian, edit file /etc/squid/squid.conf :

# nano /etc/squid/squid.conf

Cari bagian cache_dir aufs /proxy 16000 37 256 . Perhatikan yang saya tandai merah dan biru. Untuk yang saya tandai merah, itu merupakan 80% dari ukuran total disk cache saya yang sebesar 20GB. Ini merupakan prinsip penggunaan disk cache yang baik. Sehingga disitu saya tulis 16000 (satuannya megabyte). Silahkan kalian ganti dengan 80% dari total ukuran disk cache kalian masing-masing.

Sedangkan untuk yang saya tandai biru, itu diperoleh dari rumus : ukuran 80% disk cache  dalam satuan byte/13/256/256 X 2.

Kira-kira cara menghitungnya seperti ini : 16000000/13/256/256 X 2 = 37.5. Dibulatkan saja menjadi 37.

Mengubah ukuran RAM

RAM yang saya gunakan pada artikel ini adalah 2GB. Jika kalian memiliki ukuran RAM yang berbeda dari saya, untuk mengubahnya kalian perlu mengedit file tune.conf :

# nano /etc/squid/tune.conf

Cari bagian ipcache_size 4096 lalu ganti angka 4096 dengan 2X ukuran RAM kalian dalam satuan Megabyte. Sebagai contoh, disitu tertulis 4096 karena hasil dari 2 X ukuran ram saya yaitu 2048.

Setelah itu cari lagi bagian fqdncache_size 2048 lalu ganti angka 2048 dengan ukuran RAM kalian dalam satuan Megabyte. Jika sudah simpan dan tutup file tersebut.

Untuk script-script lainnya, bisa kalian pelajari sendiri dengan melihat semua file yang ada didalam direktori /etc/squid.

Testing

1. Sebelum kalian mengetes squid kalian, pertama-tama matikan terlebih dahulu service dari Squid3. Karena nanti akan bentrok dengan service milik Squid Lusca.

# service squid3 stop

2. Kemudian kalian harus membuat direktori-direktori untuk tempat penyimpanan cache didalam disk cache kalian dengan menggunakan perintah berikut :

# squid -f /etc/squid/squid.conf -z

3. Baru sekarang jalankan squidnya :

# squid -NDd1 &

Berhubung kita menjalankan squidnya pada mode background, maka setelah kalian menjalankan perintah diatas, kalian bisa tekan tombol Enter.

4. Lalu pastikan kalau squid sudah mampu menjalankan servicenya dengan file descriptor yang sudah kalian tentukan diawal, yaitu sebesar 65535 :

# squidclient mgr:info | grep 'file descri'
Maximum number of file descriptors: 65535
Available number of file descriptors: 65511

Reserved number of file descriptors: 100

5. Terakhir, pantau log file dari squid dengan perintah berikut :

# tail -f /var/log/squid/access.log | ccze



Membuat Autostart Squid

Agar service squid langsung berjalan setiap komputer menyala, maka kalian harus menambahkan script autostart baru pada direktori /etc/init.d :

# nano /etc/init.d/squid

Kopikan semua script yang ada di halaman ini http://web.suffieldacademy.org/ils/netadmin/docs/software/squid/etc/init.d/squid kedalam file tersebut. Jika sudah simpan dan tutup filenya.

nb : file /etc/init.d/squid memang kosong. jadi jangan kaget ketika kalian mengetikkan perintah diatas, ternyata malah seperti membuat file baru.

Kemudian eksekusi dua perintah berikut untuk memberikan hak akses executable dan membuat file tersebut autostart setiap komputer dijalankan :

chmod 755 /etc/init.d/squid
update-rc.d squid defaults

Selanjutnya masukkan juga script berikut pada file /etc/rc.local untuk membuat squid3 tidak berjalan setiap komputer nyala. Kalau tidak, takutnya nanti bentrok antara squid3 dengan lusca.

nano /etc/rc.local

Masukkan script ini :

service squid3 stop

Simpan dan tutup file tersebut.

Memonitor Kinerja Squid Lusca dengan Squid Analyzer

Apabila kita hanya melihat file log milik squid secara mentah, rasanya kita agak kurang paham dan kurang bisa melihat statistiknya secara lengkap. Oleh karena itu kita memerlukan tools tambahan agar kita bisa memantau file log squid dengan tampilan yang lebih user friendly. Kalian bisa membaca artikel milik saya tentang cara memonitor kinerja Squid Lusca dengan Squid Analyzer disini.

Komentar Pribadi

Seluruh konfigurasi diatas sudah sering saya coba di beberapa PC dengan spek yang berbeda, seperti Intel Pentium 4, Dual Core, Core 2 Duo, sampai Intel Core i3 dan Intel Xeon. Untuk ngehit situs-situs HTTP dan game-game HTTP seperti game facebook dan friv.com sangat lancar. Untuk ngehit youtube pun lancar. Yang kurang adalah tidak seluruh update patch game online bisa ngehit (saya baru mencoba yang bisa terHIT hanya beberapa game gemscool saja, sedangkan untuk game online selain itu tidak bisa), serta tidak bisa ngehit speedtest. Sehingga ketika di test di speedtest, hanya bisa menampilkan angka yang sesuai dengan bandwidth asli.

Saya masih dalam tahap mengoprek-oprek lagi agar kekurangan yang saya alami diatas agar bisa segera teratasi.  Apabila ada diantara kalian yang mempunyai script yang lebih mantap dari milik saya, yang mungkin bisa ngehit semua patch game online dan speedtest monggo dishare saja dengan mengomentari artikel ini.

Semoga bermanfaat :)

UPDATED 15 JUNI 2014

Artikel ini bakalan sering saya update, jadi tolong dicek secara berkala jika kalian memang membuat proxy berdasarkan artikel ini.

SUMBER

24 February 2014

Memonitor Kinerja Squid Proxy dengan Squid Analyzer di Ubuntu 12.04 Server


Sudah lama sekali rasanya saya menelantarkan blog ini. Maafkan saya ya sekarang nampaknya saya sudah mulai jarang menulis lagi, yah dengan beribu-ribu alasan dibelakangnya. Oleh karena itu bagi kalian yang ingin berkontribusi untuk menulis di blog ini demi menghidupkan kembali Linuxku.com, silahkan saja baca halaman ini ya untuk menjadi penulis di Linuxku.com. Saya sangat senang apabila ada diantara kalian yang berminat untuk menyumbangkan tulisannya disini. :)

Pada postingan kali ini, saya ingin membagikan cara memonitor kinerja squid proxy dengan Squid Analyzer.

Squid merupakan software Proxy yang sangat terkenal dikalangan Network Administrator. Berhubung begitu pentingnya squid ini, kita perlu untuk selalu memonitor kinerja sang squid agar kita mengetahui seberapa efisienkah konfigurasi yang kita punya.

Untuk melakukan monitoring Squid Proxy, ada beberapa tools yang cukup terkenal diantaranya SARG, Cacti, maupun Mysar. Namun pada postingan ini saya ingin memberikan alternatif tools lain bernama Squid Analyzer. Apa itu Squid Analyzer? Squid Analyzer merupakan salah satu tools penganalisa log milik Squid yang dapat menyajikan statistik lengkap meliputi waktu, hit, byte, pengguna, jaringan, hingga top url dan top domain yang paling sering diakses. Keunggulan yang ditawarkan dari Squid Analyzer diantaranya adalah tidak perlu adanya database apapun untuk dapat menjalankannya, dan juga tampilan Squid Analyzer ini termasuk yang cukup user friendly dibandingkan SARG ataupun Mysar.

Yuk, mending kita langsung coba saja ya.

Yang perlu disiapkan

1. Squid sudah terinstall dan jalan dengan baik. Boleh menggunakan Squid3, Squid 2.7, maupun Lusca. Saya tidak akan membahas tentang cara instalasi Squidnya ya, kalian tinggal cari saja di Google tentang cara instalasi Squidnya.

2. Install Webserver dan Perl :

$ sudo apt-get install apache2 php5 perl

Pastikan tidak ada pesan error yang muncul. Atau lihat artikel instalasi Webserver yang sudah pernah saya tulis disini.

3. Install SSH :

$ sudo apt-get install ssh

SSH disini digunakan untuk mengirim file dari client ke server menggunakan metode SCP.

Instalasi

1. Download paket SquidAnalyzer disini.

2. Kirimkan file squidanalyzer-5.3.tar.gz yang sudah kalian download dari komputer klien ke komputer server dengan menggunakan metode SCP.

Disini letak file squidanalyzer saya ada di direktori Downloads pada komputer klien dan ingin saya kirimkan ke home direktori milik user rizal yang ada di komputer server dengan ip 192.168.0.2. Maka eksekusi perintah berikut pada komputer klien :

$ scp Downloads/squidanalyzer-5.3.tar.gz rizal@192.168.0.2:

Ketik Yes jika muncul pertanyaan untuk menambahkan key SSH. Setelah itu masukkan password user rizal. Tunggu hingga proses pengiriman selesai.

3. Sekarang pindahlah ke komputer Server. Disini saya anggap kalian login sebagai user rizal. Maka kalian bisa langsung mengekstrak file squidanalyzer yang sudah kalian kirimkan sebelumnya :

$ tar -xvf squidanalyzer-5.3.tar.gz
$ cd squidanalyzer-5.3


4. Ganti menjadi user root :

$ sudo su

5. Install Squid Analyzer-nya :

# perl Makefile.PL
# make
# make install


6. Selanjutnya, khusus bagi yang menggunakan squid selain versi 3, kalian harus mengedit file konfigurasi Squid Analyzer untuk mengganti letak file log squidnya :

# nano /etc/squidanalyzer/squidanalyzer.conf

Ganti bagian LogFile /var/log/squid3/access.log menjadi LogFile /var/log/squid/access.log. Simpan dengan menekan CTRL + X > Y > Enter.


7. Berhubung Squid Analyzer adalah tools berbasis web, maka kalian harus mengedit file httpd.conf-nya apache agar webserver kalian bisa menampilkan halaman Squid Analyzernya.

# nano /etc/apache2/httpd.conf

Tambahkan script berikut didalam file tersebut :


Alias /squidreport /var/www/squidanalyzer
<Directory /var/www/squidanalyzer>
Options -Indexes FollowSymLinks MultiViews
AllowOverride None
Order deny,allow
Allow from all
</Directory>


Simpan dan tutup filenya jika sudah.


Jangan lupa restartlah webserver apache kalian :

# service apache2 restart

8. Setelah itu jalankan service squid-analyzer untuk pertama kalinya :

# /usr/local/bin/squid-analyzer

9. Agar Squid Analyzer bisa merefresh log squid setiap 10 menit sekali, maka kalian harus menambahkan script berikut kedalam jadwal cron :

# crontab -e

Jika muncul pertanyaan kalian ingin mengedit filenya menggunakan text editor apa, pilih saja text editor Nano agar mudah.

Dibaris paling bawah file konfigurasi crontab tersebut, tambahkan script ini :

*/10 * * * * /usr/local/bin/squid-analyzer > /dev/null 2>&1

Simpan jika sudah.

10. Terakhir, akseslah Squid Analyzer melalui web browser dengan mengarahkannya ke alamat http://ipserver/squidreport


Untuk cara penggunaannya eksplor sendiri saja ya. Mudah kok, tinggal klik-klik saja statistik apa yang ingin kalian tampilkan.

Statistik Harian


Statistik Tipe Mime


Statistik User


Statistik Top Domain


Semoga bermanfaat :)

23 February 2014

Membuat Form Dasar di Delphi 7

di bawah ini cara membuat form dasar tanpa merubah value properties di object inspector atau dengan istilah lain dengan hanya menggunakan coding.

procedure TForm1.FormCreate(Sender: TObject);
begin
form1.Position := poDesktopCenter;
form1.BorderStyle := bssingle;
form1.BorderIcons := BorderIcons - [bimaximize] ;
end;

end.

cara membuat agar tampilan form terletak di area tengah-tengah desktop :

form1.Position := poDesktopCenter;

20 February 2014

Cara Mencegah Client Mengganti DNS secara Manual

Bagaimana cara mencegah client mengganti DNS manual misal ke 8.8.8.8? Pertanyaan ini ada pada artikel sebelumnya yakni : Cara Mudah Memblokir Situs-situs Dewasa dengan DNS di Mikrotik. Nah pada artikel kali ini saya akan coba menjawab nya dan memberikan solusi mencegah client mengganti DNS secara manual menggunakan Mikrotik.

Sebenarnya lebih tepat kalau kita sebut "Memaksa" Client menggunakan DNS Mikrotik. Karena siapapun bisa saja merubah setingan DNS di PC nya masing-masing. Nah, hal yang akan kita lakukan ini adalah memaksa client tersebut untuk menggunakan DNS kita walaupun DNS di PC nya sudah dirubah misal ke 8.8.8.8. Gimana caranya? Simak tutorial berikut :

Tutorial Cara Mencegah Client Mengganti DNS secara Manual :
1. Login ke Mikrotik via Winbox 

2. Masuk ke menu IP --> Firewall --> NAT --> Add --> 


- Pada tab General : 
==> Chain : dstnat
==> Protocol : 17 (udp)
==> Dst. Port : 53

- Pada tab Action :
==> Action : Redirect
==> To Ports : 53

3. Coba anda cek di PC, ganti DNS ke manual misal 8.8.8.8 dan akses situs yang harusnya diblokir.
4. Jika masih bisa, coba flush dulu DNS Cache nya di Mikrotik dan PC nya

Oke, selamat mencoba tutorial Cara Mencegah Client Mengganti DNS secara Manual ini ya. Semoga sukses :)

Cara Mudah Memblokir Situs-situs Dewasa dengan DNS di Mikrotik

Memblokir Situs-situs Dewasa degan Mudah di Mikrotik
Menciptakan suasana internet yang sehat itu penting. Apalagi jika bayak client dari jaringan kita adalah anak-anak atau anak sekolah yang belum boleh mengakses konten dewasa. Masalahnya, banyak sekali situs-situs dewasa yang beredar di internet. Hal ini bakal bikin pusing jika kita harus memblokir situs nya satu per satu.

Untuk dapat memblokir situs atau konten terentu di internet pada Mikrotik dapat dilakukan dengan cara :
1. Web Proxy
2. DNS Static
3. Firewall

Memblokir situs tertentu menggunakan Web Proxy sudah pernah saya bahas disini :
 
Begitu juga dengan memblokir situs dengan Firewall Mikrotik. 

Keduanya harus memasukkan daftar situs yang akan diblokir secara manual satu per satu. Hal ini tentu akan sangat merepotkan jika jumlah situs yang akan diblokir sampai ratusan bahkan ribuan. Kendala lainnya adalah kita tidak tau situs apa saja yang harus diblokir.


Nah, oleh karena itu solusi yang cocok adalah menggunakan DNS Static. Dalam hal ini kita dapat menggunakan DNS Gratis dari Nawala atau OpenDNS yang sudah memfilter konten berbahaya. Jadi kita tidak perlu lagi repot-repot memfilter manual semua situs-situs berbahaya tersebut.

Caranya sangat mudah, silakan anda login ke Mikrotik via Winbox.

1. Jika anda menggunakan DHCP Client, misalnya menggunakan internet dari speedy atau modem GSM maka anda harus menonaktifkan fitur "Use Peer DNS"
Masuk ke menu IP --> DHCP Client --> Buka DHCP client nya -- > uncheck "Use Peer DNS"



2. Masuk ke menu IP --> DNS --> Masukkan DNS Server nya di kolom Servers --> centang Allow Remote Request



- DNS Nawala (gratis tanpa register) :
  • 180.131.144.144
  • 180.131.145.145
- DNS OpenDNS (gratis register dulu) --> opendns.com

Bedanya jika menggunakan DNS Nawala jika masuk ke situs yang terblokir muncul pesan tetapi tidak dpat diganti. Sedagkan kalo OpenDNS bisa kita masukkan pesan tertentu sesuai keinginan seperti pada gambar pertama diatas.

Selain itu, jika menggunakan DNS Nawala kita ga bisa menambahkan atau mengurangi situs yang diblokir, sedangkan kalo menggunakan DNS OpenDNS bisa diatur situs apa saja yang mau diblokir. Namun jika menggunakan OpenDNS harus register dulu.

3. Setelah diganti DNS nya, jangan lupa untuk Flush DNS Cache nya. Pada menu DNS Settings --> Cache --> Flush Cache


atau bisa menggunakan command :
ip dns cache flush
4. Lakukan flush DNS cache juga pada windows dengan command di CMD :
ipconfig /flushdns

Nah, sekarang siapapun yang mengakses konten dewasa akan diblokir oleh DNS server. Namun masalahnya, bagaimana jika client mengganti alamat DNS nya secara manual misal pake DNS google 8.8.8.8? Hal ini akan membuat pemblokiran ini menjadi sia-sia.

Sekarang pertanyaannya, bagaimana cara mencegah client mengganti DNS manual misal ke 8.8.8.8? Caranya dengan memaksa client untuk menggunkaan DNS dari Mikrotik kita. Tutorialnya silakan anda baca disini :
Cara Mencegah Client Mengganti DNS secara Manual

Oke, demikianlah Cara Mudah Memblokir Situs-situs Dewasa dengan DNS di Mikrotik. Silakan dicoba, dan semoga bermanfaat :)

19 February 2014

Mengganti Tampilan Halaman Error Webproxy Mikrotik

Tampilan Halman error pada Webproxy Mikrotik dapat kita rubah sesuai keingininan. Tampilan asli halaman error web proxy Mikrotik adalah sebagai berikut :
 
Kita dapat merubah tampilan tersebut dengan mengganti/merubah script yang ada di file /webproxy/error.hrml pada mikrotik. 


Namun jika direktori dan file tersebut tidak muncul di Mikrotik, maka anda harus mereset file HTML nya.
1. Masuk ke menu IP --> Web Proxy --> Reset HTML


2. Copy file error.html via File List atau akses FTP Mikrotik


3. Silakan anda edit filenya atau ganti dengan error page anda sendiri.

4. Yang perlu diperhatikan adalah, tidak semua kode HTML dapat dieksekusi di halaman error ini. Misalnya : tidak dapat menampilkan gambar atau animasi lainnya.

5. Jika anda ingin menambahkan gambar pada halaman error nya, file gambar nya bisa dirubah dulu ke dalam base64 string di web ini
http://webcodertools.com/imagetobase64converter

6. Selanjutnya bisa masukkan code HTML hasil convert nya ke halaman error tadi. Contoh nya seperti ini :


7. Hasilnya seperti ini :


Oke sekian dulu Tutorial Mengganti Tampilan Halaman Error Webproxy Mikrotik ini. Silakan anda coba :)

08 February 2014

Modem Manager GUI di Ubuntu

Modem, mungkin ini menjadi salah satu penghalang sobat-sobat semua memakai ubuntu atau keluarga linux lainnya, karena males koneksikan modem atau tidak faham cara koneksi modem di ubuntu atau tidak kompatibel modemnya nah bagi yang mengalami kendala diatas saya sudah mencoba bereksperimen dengan berbagai cara dan ini hasilnya :



Dasar Konfigurasi Semua Modem USB di Ubuntu
Konfigurasi Modem USB

07 February 2014

Cara Belajar Mikrotik dari Awal : Dasar Seting Mikrotik

Pada dasarnya blog Tutorial Mikrotik Indonesia ini memang di buat untuk menyajikan tutorial dasar Mikrotik bagi pemula berupa setingan dasar Mikrotik dari awal. Nah, untuk itu bagi anda yang baru mengenal mikrotik dan ingin belajar lebih banyak tentang Mikrotik, silakan simak artikel yang ada di blog ini :

http://mikrotikindo.blogspot.com/

1. Sebelum anda mulai belajar Mirotik, ada baiknya anda belajar dulu tentang dasar jaringan komputer disini :

2. Selanjutnya anda juga perlu tau tentang dasar-dasar istilah Mikrotik berikut :  

3. Jika anda ingin menggunakan Mikrotik tanpa Router Board, yaitu dengan menginstall Mikrotik di PC, silakan simak artikel berikut ini :

4. Untuk mengakses Mikrotik anda dari PC dilakukan dengan cara-cara berikut ini :  

5. Selanjutnya anda dapat konfigurasi Mikrotik anda sesuai dengan keinginan dan tujuan anda. Silakan cari tutorial yang sesuai seperti disini :

Jika anda punya pertanyaan seputar mikrotik jangan sungkan untuk bertanya di kolom komentar, atau silakan gabung ke Forum MikrotikIndo di Facebook dengan like Facebook page ini :

05 February 2014

Cara Memblokir Situs Menggunakan Web Proxy MikroTik

Web Proxy Mikrotik memiliki beberapa fungsi, salah satunya yaitu fungsi filtering. Fitur Filtering Web Proxy ini dapat membatasi akses konten-konten tertentu yang di-request oleh client. Anda dapat membatasi akses ke situs tertentu, ekstensi file tertentu, melakukan redirect (pengalihan) ke situs lain, maupun pembatasan terhadap metode akses HTTP. Hal tersebut tidak dapat anda lakukan jika hanya menggunakan NAT. Penjelasan selengkapnya tentang Web Proxy Mikrotik ada disini :

Selanjutnya kita akan coba memblokir sebuah situs tertentu menggunakan fitur filtering Web Proxy ini. Pastikan Transparent Web Proxy Mikrotik sudak aktif. Jika belum silakan anda seting sesuai tutorial berikut ini :

Jika Transparent Web Proxy sudah aktif, kita mulai langkah-langkah Cara Memblokir Situs Menggunakan Web Proxy MikroTik berikut ini :

1. Login ke Mikrotik dengan Winbox

2. Masuk ke menu IP --> Web Proxy --> Access --> Add rule baru



3. Masukkan detail website yang mau di blok
> Dst. Port : isikan port http 80
> Dst. Host : isikan alamat website yang mau di blok misalnya www.rizkyagung.com
> Action : pilih deny untuk memblokir akses nya


4. Sebelum rule nya diaktifkan pastikan cek website yang mau di blok itu bisa dibuka apa tidak.



5. Aktifkan rule nya, dan cek apakah website sudah berhasil di blokir. Jika sukses maka akan tampil halaman error seperti ini :



6. Kita juga bisa memodifikasi rule nya dengan me-redirect ke situs lain. Misalnya ketika ada user yang mengakses web www.rizkyagung.com maka akan langsung dialihkan (redirect) ke blog ini MikrotikIndo.blogspot.com. 
Tinggal isikan saja alamat website nya di kolom Redirect To :



Oke, silakan anda coba dan isikan website apa saja yang mau diblokir. Selamat mencoba Cara Memblokir Situs Menggunakan Web Proxy MikroTik ini :)

Menambah Cache Proxy Mikrotik Menggunakan USB Flashdisk

Salah satu fitur dari Mikrotik adalah Web Proxy. Namun, jika menggunakan web proxy internal Mikrotik, kadang kurang maksimal karena ukuran cache drive internal nya terbatas, menyesuaikan ukuran memori internal Mikrotik nya. Jika anda menggunakan PC sebagai Mikrotik, bisa memanfaatkan harddisk nya untuk ditambahkan sebagai cache drive web proxy Mikrotik. Namun, jika Mikrotik nya berupa Router Board tidak bisa dilakukan. Tapi jangan khawatir, pada Router Board tipe-tipe tertentu yang sudah mendukung port USB bisa ditambahkan memori external sebagai cache drive web proxy Mikrotik.

Nah, kali ini saya akan membahas tentang penggunaan memori external USB berupa Flashdisk / Harddisk external sebagai cache drive tambahan pada Web Proxy Mikrotik yang support port USB. Ada beberapa tipe Router Board yang sudah support USB, seperti RB750UP, RB751U-2HnD, RB951Ui-2HnD, dsb. Dalam hal ini saya menggunakan RB951Ui-2HnD dan USB Flashdisk 8 GB sebagai cache drive Web Proxy.

Sebelumnya, pastikan web proxy anda sudah diaktifkan. Jika belum, silakan baca tutorial berikut ini :
Jika sudah, silakan siapkan Router Board anda dan sebuah USB Flashdisk. Anda juga bisa menggunakan hard disk external, tapi pastikan tidak ada data penting yang ada di dalamnya. Karena USB ini harus di format ulang dulu oleh Mikrotik agar dapat digunakan.

1. Colokan USB Flashdisk ke port USB RouterBoard anda
2. Nyalakan Mikrotik RouterBoard anda
3. Buka Winbox, masuk ke menu System --> Stores --> Masuk tab Disks --> Pilih USB nya --> Klik Format Drive. 


Jika berhasil maka status USB drive nya akan berubah menjadi Ready

4. Pindah ke tab Store --> Klik [+] 


> Beri nama terserah
> Type : web-proxy
> Disk : pilih usb1
> centang Acrivate
> Ok

5. Coba cek di menu Web Proxy : IP --> Web Proxy --> Cek bagian Cache Drive seharusnya sudah berubah dari system ke usb1



6. Cek di tab Status, Jika web proxy sudah digunakan seharusnya Cache Used nya akan mulai dari 0 lagi dan terus bertambah ketika digunakan browsing.


Nah, sekarang memori yang digunakan untuk menyimpan cache Web Proxy Mikrotik sudah bertambah besar. Jadi akan lebih banyak file yang bisa ditampung di cache proxy nya. 
Semoga bermanfaat :)

04 February 2014

Contoh Cara Seting Load Balance Mikrotik 2 ISP

Artikel kali ini kembali membahas tentang Load Balancing, yaitu Contoh Cara Seting Load Balance Mikrotik 2 ISP. Disini ada 2 ISP berbeda yang digunakan, yaitu Bandwith ISP A 1024 Kbps Sedangkan ISP  B 256 Kbps 1:8 Tetapi di sini kita akali menambah satu fake ISP untuk seimbangkan akses Langsung. 

Berikut langkah-langkah nya :

Pake WinBox masuk ke -> IP -> Address
-> klik [+] -> isikan Address : 192.168.1.1/24 Network : 192.168.1.0
Broadcast : 192.168.1.255 -> Konfigurasi LAN ( Local)
Interface : Ether1

-> klik [
+] -> isikan Address : 192.168.2.2/24
Network : 192.168.2.0
Broadcast : 192.168.2.255 -> Konfigurasi WAN 1 (ISP A)
Interface : Ether2

-> klik [
+] -> isikan Address : 192.168.3.2/24  Network : 192.168.3.0
Broadcast : 192.168.3.255 -> Konfigurasi WAN 2 (ISP B)
Interface : Ether3

Buat Mangle. Pake WinBox pilih -> New Terminal
Silakan copy dan paste script berikut :
/ip firewall mangle [lalu enter]
add chain=prerouting in-interface=”ether1″ connection-state=new nth=2,2,0 action=mark-connection new-connection-mark=lb_1 passthrough=yes comment=”LB Client” disabled=no
add chain=prerouting in-interface=”ether1″ connection-mark=lb_1 action=mark-routing new-routing-mark=route_lb_1 passthrough=no comment=”" disabled=no
add chain=prerouting in-interface=”ether1″ connection-state=new nth=2,2,1 action=mark-connection new-connection-mark=lb_2 passthrough=yes comment=”" disabled=no
add chain=prerouting in-interface=”ether1″ connection-mark=lb_2 action=mark-routing new-routing-mark=route_lb_2 passthrough=no comment=”" disabled=no
add chain=prerouting in-interface=”ether1″ connection-state=new nth=2,2,2 action=mark-connection new-connection-mark=lb_3 passthrough=yes comment=”" disabled=no
add chain=prerouting in-interface=”ether1″ connection-mark=lb_3 action=mark-routing new-routing-mark=route_lb_3 passthrough=no comment=”" disabled=no

Buat NAT. Pake WinBox pilih -> New Terminal
Copy dan paste lagi script berikut :
/ ip firewall nat
add chain=srcnat out-interface=”ether3″ action=masquerade comment=”" disabled=no
add chain=srcnat out-interface=”ether2″ action=masquerade comment=”" disabled=no

Buat Route. Pake WinBox pilih -> New TerminalCopy dan paste lagi script berikut :
 / ip route
add dst-address=0.0.0.0/0 gateway=192.168.2.1 scope=255 target-scope=10 routing-mark=route_lb_1 comment=”" disabled=no
add dst-address=0.0.0.0/0 gateway=192.168.3.1 scope=255 target-scope=10 routing-mark=route_lb_2 comment=”" disabled=no
add dst-address=0.0.0.0/0 gateway=192.168.2.1 scope=255 target-scope=10 routing-mark=route_lb_3 comment=”" disabled=no
add dst-address=0.0.0.0/0 gateway=192.168.2.1 scope=255 target-scope=10 comment=”default routing connection” disabled=no
Untuk Interface dan IP address nya silakan anda sesuaikan sendiri dengan kebutuhan anda. Demikianlah Contoh Cara Seting Load Balance Mikrotik 2 ISP
Selamat Mencoba :)

Cara Seting Auto Shutdown Mikrotik Menggunakan Winbox

Ada kalanya disaat-saat tertentu kita ingin mematikan Mikrotik secara otomoatis tanpa perlu repot-repot mengakses Mikrotik nya dulu kemudian baru di shutdown. Hal tersebut dapat kita lakukan dengan memanfaatkan fitur script dan schedule pada Mikrotik untuk membuat metode Auto Shutdown Mikrotik. Dengan bantuan kedua fitur ini kita bisa mematikan Mikrotik pada jam dan waktu yang kita inginkan.

Jadi Skenario nya seperti ini :
Saya punya Mikrotik RB951U-2HnD untuk hotspot via modem smartfren di kos. Mikrotik ini cuma dipakai dari jam 6 sore (pulang kerja) hingga 6.40 pagi (berangkat kerja). Karena pas kerja, mikrotik saya bawa ke kantor buat hotspotan. Di kantor Mikrotik beroperasi dari jam 7.30 pagi hingga jam 5 sore. Jadi disini saya ingin membuat Mikrotik shutdown otomatis pada pukul 06.40 dan 17.00. Untuk tau lebih lanjut, silakan simak caranya.

Caranya adalah sebagai berikut :
1. Login ke Mikrotik via Winbox
2. Buka menu System --> Scripts --> Tembahkan Script Baru
> Beri nama Script nya, misal autoshutdown
> Masukkan script berikut pada kolom Source:
system shutdown

3. Untuk menjalankan Script Auto Shutdown secara otomatis tiap harinya, buka menu System --> Scheduler --> Tambahkan schdule baru
> Beri nama schedule nya.
> Start Date : isi tanggal kapan script ini akan mulai dieksekusi
> Start Time : Jam berapa script akan dieksekusi
> Interval : berapa selang waktu (interval) script ini akan dieksekusi lagi (1d = 1 hari = 24 jam)
> On Event : nama script yang sudah dibuat dan akan di eksekusi


4. Script autoshutdown dapat dieksekusi lebih dari sekali. Caranya tinggal tambahkan lagi saja Schedule nya dengan seting waktu yang berbeda.

Oke, silakan anda coba dan praktekkan Tutorial Cara Seting Auto Shutdown Mikrotik Menggunakan Winbox ini. Semoga bermanfaat :)