31 March 2014

Cara Mengatasi Lampu LED Mikrotik Kelap-Kelip

Saya punya Mikrotik RB751U-2HnD yang saya gunakan untuk hotspot di rumah. 3 bulan saya tinggal ke luar kota, ternyata Mikrotik nya rusak. Semua lampu LED nya kelap-kelip seperti lampu disco, kecuali LED wlan nya. Saya cari tahu, kenapa bisa begitu. Usut punya usut, ternyata Mikrotik ini sering dimatikan langsung tanpa shutdown yang benar. Saya kira Mikrotik nya sudah rusak, karena tidak bisa berjalan normal, dan tidak bisa diakses melalui winbox. 



Saya coba cari solusinya di internet, ternyata ada juga yang mengalami hal serupa. Mereka menyarankan untuk mengganti Power Supply original mikrotik 12 V DC dengan Power Supply lain yang punya tegangan lebih tinggi. Kemudian saya coba gunakan Power Supply lain dengan tegangan 15 V DC. Ternyata Mikrotik nya mau nyala, lampu LED nya tidak lagi kedap-kedip seperti lampu disco. Mikrotik bekerja dengan normal kembali. Saya juga bisa mengakses mikrotik nya via winbox dan setingan yang dulu pun tidak hilang.

Jadi, dari masalah Lampu LED Mikrotik Kelap-Kelip ini solusinya yaitu dengan mengganti power supply mikrotik. Saya sarankan untuk mengganti Power Supply nya dengan Power Supply original Mikrotik 24 V DC.

Untuk lebih jelasnya, liat video yang saya buat khusus untuk anda berikut ini :
 

Daftar Port Game Online Indonesia Untuk Kebutuhan Mikrotik


Bagi kalian yang sering berkutat dengan Mikrotik dan Warnet Game Online, tentunya kalian sering membutuhkan daftar port-port yang digunakan oleh game online di Indonesia. Daftar port ini nantinya akan digunakan untuk proses marking mangle agar jalur game online dengan jalur browsing dapat dipisahkan.

Silahkan klik link dibawah ini untuk mendownload Daftar Port Game Online Indonesia Untuk Kebutuhan Mikrotik :


Semoga bermanfaat :)

Dari berbagai sumber

30 March 2014

Mengatasi Error : Live Preview Error Aplikasi Brackets di Ubuntu 13.10

Brackets adalah aplikasi editor HTML, CSS, dan Javascript yang cukup powerful untuk belajar mendesain sebuah web. Aplikasi inilah yang saat ini sering saya gunakan untuk belajar membuat dan mendesain web di Ubuntu 13.10. Bagi kalian yang tertarik untuk menginstall aplikasi ini di Ubuntu kalian, silahkan merujuk ke link ini saja ya.

Di ubuntu 13.10, pada saat pertama kali menjalankan fitur Live Preview, ternyata muncul error seperti ini :


Untuk mengatasi error tersebut, ternyata caranya cukup mudah. Berhubung error tersebut hanya karna masalah permission saja, maka kalian cukup ketikkan perintah berikut :

$ sudo chmod -R 777 /opt/brackets


Semoga bermanfaat :)

29 March 2014

Ebook Pemrograman Bahasa C di Linux Bahasa Indonesia


Linux kayaknya ga lengkap yah tanpa programming hehehe, nih kali ini saya suguhkan materi tentang programming sob, dan ini bahasa nya bahasa 'dewa' yaitu bahasa C.









Ebook Pemrograman Bahasa C di Linux ini berasal dari salah satu teman facebook yang aktif di forum linux sob yaitu mas Ade Malsasa Akbar terima kasih untuk beliau.



lanjut sob di ebok ini ada beberapa bahasan penting yang

Ubuntu 14.04 "Final Beta" Telah dirilis


Ubuntu versi LTS terbaru yaitu ubuntu 14.04 telah dirilis, meskipun statusnya "Final Beta" bukan lajang tapi layak buat kita coba sob, istilahnya freetest lah :D. Ubuntu versi 14.04 ini dikenal dengan codename "trusty tahr" atau kambing gunung sob lumayan buat kurban.









Beberapa fitur yang ditingkatkan seperti :


Unity layar kunci yang baru
Kinerja Dash menjadi lebih baik
Unity Center

27 March 2014

Cara Agar Server Tidak Bisa di Ping di Ubuntu 12.04 Server LTS

Salah satu cara untuk mengamankan Server Ubuntu kalian adalah dengan membuat agar Server kalian tidak dapat di ping. Cara ini dapat membuat seakan-akan Server kalian dalam keadaan Offline, karena rata-rata setiap orang jika ingin mengetes apakah suatu komputer dalam keadaan online atau tidak adalah dengan melakukan ping.

Cara untuk membuat Server Tidak Bisa di Ping di Ubuntu 12.04 Server LTS adalah dengan menambahkan script pada file /etc/sysctl.conf :

$ sudo vim /etc/sysctl.conf

Pada baris paling bawah, tambahkan script berikut ini :

#Ignore ICMP request:
net.ipv4.icmp_echo_ignore_all = 1

#Ignore Broadcast request:
net.ipv4.icmp_echo_ignore_broadcasts = 1



Simpan file tersebut.

Semoga bermanfaat :)

Cara Mencari File Berdasarkan Isi Filenya di Linux


Kemarin saya mengalami satu kejadian. Suatu saat saya lupa telah meletakkan file saya ada dimana, dan kebetulan saya sangat membutuhkan file tersebut. Tapi untungnya saya ingat isi dari file tersebut. Akhirnya saya pun mencoba mencari di google tentang bagaimana cara mencari file berdasarkan isi filenya di Linux, dan berikut adalah scriptnya :

$ sudo find /etc/zpanel/ -name "*.*" -print | xargs grep "rizal.keren"

Keterangan :
biru : letak direktori yang ingin dicari. Jika ingin mencari di keseluruhan sistem, maka tulis saja /
merah : salah satu kata kunci atau kalimat dari isi file kalian

Semoga bermanfaat :)

26 March 2014

Install DenyHosts di Ubuntu 12.04 Server LTS

DenyHosts merupakan program yang ditulis menggunakan bahasa Phyton yang dapat membanned IP secara otomatis jika ada yang mencoba melakukan serangan Brute Force (mencoba melakukan login berulang-ulang dengan memasukkan password secara random) terhadap Server kalian. Aplikasi ini sering digunakan sebagai salah satu cara pengamanan SSH yang cukup ampuh.

Untuk menginstall DenyHosts di Ubuntu 12.04 Server LTS cukup ketikkan perintah berikut ini :

$ sudo apt-get install denyhosts


Setelah terinstall, kalian dapat memasukkan IP-IP yang kalian anggap dapat dipercaya pada file /etc/hosts.allow, sehingga akan diloloskan oleh DenyHosts walaupun salah dalam memasukkan password berulang-ulang.

$ sudo nano /etc/hosts.allow

Tambahkan baris berikut ini apabila kalian ingin memperbolehkan akses dari IP 1.2.3.4 :

sshd: 1.2.3.4

Simpan file tersebut.

Jika sudah restart service DenyHosts-nya :

$ sudo service denyhosts restart

Sebenarnya, denyhosts sudah berfungsi dengan baik pada saat baru kita install. Tapi jika kalian ingin melakukan konfigurasi tambahan, tinggal kalian edit saja file /etc/denyhosts.conf :

$ sudo nano /etc/denyhosts.conf

Semoga bermanfaat :)

SUMBER

Development Release: OpenMandriva Lx 2014.0 Alpha 2

The OpenMandriva distribution is a full-featured Linux desktop and server, sponsored by the OpenMandriva Association. It is based on ROSA, a Russian Linux distribution project which forked Mandriva Linux in 2012, incorporating many of Mandriva's original tools and utilities and adding in-house enhancements.

The goal of OpenMandriva is to facilitate the creation, improvement, promotion and distribution of free and open-source software in general, and OpenMandriva projects in particular.

Kate Lebedeff has announced the availability of the second alpha release of OpenMandriva Lx 2014.0: "OpenMandriva Lx 2014 alpha 2 is here. To keep up to high standards we have decided to move the beta to the RC1 date and have the alpha 2 today, to deliver more fun to you. This change does not affect the final release date. 


 OpenMandriva Lx 2014.0 has been improving with every iteration – we've tried to make sure that your system works in a stable yet powerful manner. The kernel has been upgraded to 3.12.13 nrjQL – a powerful variant of the 3.12.13 kernel. 

The CPU and RCU have been configured with full pre-emption and boost mode, while we've also added the CK1 and BFQ patchsets to provide optimisations (including a better CPU load scheduler, better disk I/O scheduler, a better memory manager via UKSM, and TuxOnIce for better suspension and hibernation), designed with desktop system performance and responsiveness in mind."

Read the detailed release announcement for more information and screenshots. Download link: OpenMandriva.alpha.20140228.x86_64.iso (1,490MB, MD5).

Home Page http://openmandriva.org/
Mailing Lists http://ml.openmandriva.org/
User Forums http://forums.openmandriva.org/
Documentation http://wiki.openmandriva.org/
Screenshots LinuxScreenshots.org
Download Mirrors http://openmandriva.org/en/download_lx
Bug Tracker http://issues.openmandriva.org/
Related Websites OpenMandriva Turkey
Reviews 2013.0: DistroWatchLinuxBSDosBlogspotNavy Christian

24 March 2014

Kejadian-Kejadian 'Lucu' Ketika Mengajak Memakai Linux


Postingan kali ini adalah kumpulan dari berbagai kejadian yang saya dan teman-teman saya alami ketika mempromosikan Linux kepada orang-orang sekitar dan cerita untuk sobat tiru nih hehehe. Ada ada saja sob kisahnya, ada yang sok tau, ada yang alasan, dll. Berikut beberapa *NB jika sobat punya cerita juga share yah!










1. Ngga Ngerti MS Office

Suatu ketika teman saya bertanya.. S : Saya T

21 March 2014

Install Owncloud Cloud Server di Ubuntu 12.04 Server LTS

Jaman sekarang merupakan jamannya Cloud Computing. Salah satu implementasi dari sistem Cloud Computing adalah menjamurnya berbagai layanan Cloud Storage di internet, baik itu yang gratis maupun yang berbayar. Beberapa contoh yang terkenal adalah Dropbox, Ubuntuone, Skydrive, dan Google Drive.

Pada artikel kali ini, saya akan membahas cara pembuatan sebuah Cloud Server pribadi di Ubuntu 12.04 Server dengan menggunakan aplikasi Owncloud.


Owncloud merupakan salah satu aplikasi Cloud Storage Open Source yang memiliki beberapa fitur yang cukup bagus. Diantaranya adalah fitur Sinkronisasi otomatis dengan komputer, web, dan bahkan Smartphone. Selain itu Owncloud juga memiliki fitur sinkronisasi kontak dan kalender langsung ke Android.

Untuk instalasi Owncloud di Ubuntu 12.04 Server, ikuti langkah-langkah sebagai berikut :

1. Instal terlebih dahulu webserver di komputer kalian :

$ sudo apt-get install apache2 php5 mysql-server phpmyadmin

Nanti akan muncul beberapa pertanyaan untuk mengisi password dan sebagainya, isikan saja sesuai petunjuk yang ada. Jika kalian tidak tahu, silahkan lihat caranya pada artikel saya di Cara Instalasi Webserver di Debian

2. Download paket Owncloud terbaru :

$ wget http://download.owncloud.org/community/owncloud-6.0.2.tar.bz2

3. Setelah download selesai, Ekstraklah file owncloud-6.0.0a.tar.bz2 dengan perintah ini :

$ tar -xvf owncloud-6.0.0a.tar.bz2

4. Kopikan folder owncloud hasil ekstraksi ke dalam direktori webserver kalian sekaligus berikan juga hak kepemilikan direktori tersebut menjadi milik user www-data :

$ sudo cp -R owncloud /var/www
$ sudo chown -R www-data.www-data /var/www/owncloud


5. Selanjutnya kalian harus membuat database sekaligus usernya khusus untuk menghandle aplikasi owncloud. Login terlebih dahulu ke Mysql :

$ mysql -u root -p
mysql> CREATE DATABASE dbowncloud;
mysql> CREATE USER owncloud;
mysql> SET PASSWORD FOR owncloud = PASSWORD("123");
mysql> GRANT ALL PRIVILEGES ON dbowncloud.* TO owncloud@localhost IDENTIFIED BY '123';
mysql> FLUSH PRIVILEGES;


nb : untuk yang saya tandai berwarna merah dan biru, silahkan kalian ganti sesuai dengan keinginan kalian masing-masing.

6. Sekarang tinggalkan komputer server kalian, lalu bukalah web browser dari komputer klien dan arahkan ke alamat http://ipserver/owncloud kemudian isikan data-data yang diperlukan. Untuk username dan password admin, bisa diisikan terserah kalian. Sedangkan untuk informasi koneksi database, sesuaikan dengan database yang sudah kalian buat sebelumnya pada step 5. Jika sudah klik Finish Setup :


Pastikan tidak ada pesan error apapun ketika instalasi.

7. Berikut adalah tampilan ketika kalian sudah berhasil login ke dalam owncloud :


Semoga bermanfaat :)

20 March 2014

Perintah Terminal untuk Menampilkan Informasi Hardware di Ubuntu


Ini judul nggak efektif nih sepertinya hahaha ah masa bodo yang penting isinya efektif toh sob :D. Terkadang kita lupa spesifikasi hardware komputer atau cuma pengen ngecek spesifikasi hardware kita dengan detil mmm bisa juga buat pamer ke OS sebelah biar kerenan dikit sob hehehe.

Berikut list perintanya sob :





1. lsusb
Command line ini digunakan untuk mengetahui hardware yang menggunakan

19 March 2014

Memblokir Port Virus di Mikrotik Menggunakan Firewall

Penyebaran virus dan malware di jaringan dapat terjadi jika kita tidak selektif dalam mengaktifkan port apa saja yang digunakan. Untuk mengamankan jaringan dari penyebaran virus dan malware, kita dapat menutup port komunikasi yang tidak digunakan dan rentan dimanfaatkan oleh virus. Caranya dengan menggunakan rule firewall Mikrotik untuk men-drop paket yang masuk ke port yang tidak digunakan.

Caranya sangat mudah, silakan anda copy paste command berikut ini ke terminal Mikrotik :


/ ip firewall filter
add chain=virus protocol=tcp dst-port=135-139 action=drop comment="Blaster Worm"
add chain=virus protocol=udp dst-port=135-139 action=drop comment="Messenger Worm"
add chain=virus protocol=tcp dst-port=445 action=drop comment="Blaster Worm"
add chain=virus protocol=udp dst-port=445 action=drop comment="Blaster Worm"
add chain=virus protocol=tcp dst-port=593 action=drop comment="________"
add chain=virus protocol=tcp dst-port=1024-1030 action=drop comment="________"
add chain=virus protocol=tcp dst-port=1080 action=drop comment="Drop MyDoom"
add chain=virus protocol=tcp dst-port=1214 action=drop comment="________"
add chain=virus protocol=tcp dst-port=1363 action=drop comment="ndm requester"
add chain=virus protocol=tcp dst-port=1364 action=drop comment="ndm server"
add chain=virus protocol=tcp dst-port=1368 action=drop comment="screen cast"
add chain=virus protocol=tcp dst-port=1373 action=drop comment="hromgrafx"
add chain=virus protocol=tcp dst-port=1377 action=drop comment="cichlid"

add chain=virus protocol=tcp dst-port=2745 action=drop comment="Bagle Virus"
add chain=virus protocol=tcp dst-port=2283 action=drop comment="Dumaru.Y"
add chain=virus protocol=tcp dst-port=2535 action=drop comment="Beagle"
add chain=virus protocol=tcp dst-port=2745 action=drop comment="Beagle.C-K"
add chain=virus protocol=tcp dst-port=3127-3128 action=drop comment="MyDoom"
add chain=virus protocol=tcp dst-port=3410 action=drop comment="Backdoor OptixPro"
add chain=virus protocol=tcp dst-port=4444 action=drop comment="Worm"
add chain=virus protocol=udp dst-port=4444 action=drop comment="Worm"
add chain=virus protocol=tcp dst-port=5554 action=drop comment="Drop Sasser"
add chain=virus protocol=tcp dst-port=8866 action=drop comment="Drop Beagle.B"
add chain=virus protocol=tcp dst-port=9898 action=drop comment="Drop Dabber.A-B"
add chain=virus protocol=tcp dst-port=10000 action=drop comment="Drop Dumaru.Y"
add chain=virus protocol=tcp dst-port=10080 action=drop comment="Drop MyDoom.B"
add chain=virus protocol=tcp dst-port=12345 action=drop comment="Drop NetBus"
add chain=virus protocol=tcp dst-port=17300 action=drop comment="Drop Kuang2"
add chain=virus protocol=tcp dst-port=27374 action=drop comment="Drop SubSeven"
add chain=virus protocol=tcp dst-port=65506 action=drop comment="Drop PhatBot,Agobot, Gaobot"
add chain=virus protocol=udp dst-port=12667 action=drop comment="Trinoo" disabled=no
add chain=virus protocol=udp dst-port=27665 action=drop comment="Trinoo" disabled=no
add chain=virus protocol=udp dst-port=31335 action=drop comment="Trinoo" disabled=no
add chain=virus protocol=udp dst-port=27444 action=drop comment="Trinoo" disabled=no
add chain=virus protocol=udp dst-port=34555 action=drop comment="Trinoo" disabled=no
add chain=virus protocol=udp dst-port=35555 action=drop comment="Trinoo" disabled=no
add chain=virus protocol=tcp dst-port=27444 action=drop comment="Trinoo" disabled=no
add chain=virus protocol=tcp dst-port=27665 action=drop comment="Trinoo" disabled=no
add chain=virus protocol=tcp dst-port=31335 action=drop comment="Trinoo" disabled=no
add chain=virus protocol=tcp dst-port=31846 action=drop comment="Trinoo" disabled=no
add chain=virus protocol=tcp dst-port=34555 action=drop comment="Trinoo" disabled=no
add chain=virus protocol=tcp dst-port=35555 action=drop comment="Trinoo" disabled=no
add action=drop chain=forward comment=";;Block W32.Kido - Conficker" disabled=no protocol=udp src-port=135-139,445
add action=drop chain=forward comment="" disabled=no dst-port=135-139,445 protocol=udp
add action=drop chain=forward comment="" disabled=no protocol=tcp src-port=135-139,445,593
add action=drop chain=forward comment="" disabled=no dst-port=135-139,445,593 protocol=tcp
add action=accept chain=input comment="Allow limited pings" disabled=no limit=50/5s,2 protocol=icmp
add action=accept chain=input comment="" disabled=no limit=50/5s,2 protocol=icmp
add action=drop chain=input comment="drop FTP Brute Forcers" disabled=no dst-port=21 protocol=tcp src-address-list=FTP_BlackList
add action=drop chain=input comment="" disabled=no dst-port=21 protocol=tcp src-address-list=FTP_BlackList
add action=accept chain=output comment="" content="530 Login incorrect" disabled=no dst-limit=1/1m,9,dst-address/1m protocol=tcp
add action=add-dst-to-address-list address-list=FTP_BlackList address-list-timeout=1d chain=output comment="" content="530 Login incorrect" disabled=no protocol=tcp
add action=drop chain=input comment="drop SSH&TELNET Brute Forcers" disabled=no dst-port=22-23 protocol=tcp src-address-list=IP_BlackList
add action=add-src-to-address-list address-list=IP_BlackList address-list-timeout=1d chain=input comment="" connection-state=new disabled=no dst-port=22-23 protocol=tcp src-address-list=SSH_BlackList_3
add action=add-src-to-address-list address-list=SSH_BlackList_3 address-list-timeout=1m chain=input comment="" connection-state=new disabled=no dst-port=22-23 protocol=tcp src-address-list=SSH_BlackList_2
add action=add-src-to-address-list address-list=SSH_BlackList_2 address-list-timeout=1m chain=input comment="" connection-state=new disabled=no dst-port=22-23 protocol=tcp src-address-list=SSH_BlackList_1
add action=add-src-to-address-list address-list=SSH_BlackList_1 address-list-timeout=1m chain=input comment="" connection-state=new disabled=no dst-port=22-23 protocol=tcp
add action=drop chain=input comment="drop port scanners" disabled=no src-address-list=port_scanners
add action=add-src-to-address-list address-list=port_scanners address-list-timeout=2w chain=input comment="" disabled=no protocol=tcp tcp-flags=fin,!syn,!rst,!psh,!ack,!urg
add action=add-src-to-address-list address-list=port_scanners address-list-timeout=2w chain=input comment="" disabled=no protocol=tcp tcp-flags=fin,syn
add action=add-src-to-address-list address-list=port_scanners address-list-timeout=2w chain=input comment="" disabled=no protocol=tcp tcp-flags=syn,rst
add action=add-src-to-address-list address-list=port_scanners address-list-timeout=2w chain=input comment="" disabled=no protocol=tcp tcp-flags=fin,psh,urg,!syn,!rst,!ack
add action=add-src-to-address-list address-list=port_scanners address-list-timeout=2w chain=input comment="" disabled=no protocol=tcp tcp-flags=fin,syn,rst,psh,ack,urg
add action=add-src-to-address-list address-list=port_scanners address-list-timeout=2w chain=input comment="" disabled=no protocol=tcp tcp-flags=!fin,!syn,!rst,!psh,!ack,!urg
Hasilnya akan jadi seperti ini :


Nah, sekarang kita sudah berhasil Memblokir Port Virus Menggunakan Firewall di Mikrotik.
Semoga bermanfaat :)

18 March 2014

Cara Memperbolehkan/Mengaktifkan Directory Indexing Apache Webserver di Ubuntu 12.04 Server LTS

Akhir-akhir ini saya baru dapat kerjaan buat ngoprek webserver Apache lagi. Setelah konfigurasi sana-sini, ternyata ada sebuah masalah yang muncul. Yaitu ketika si webserver tidak mau menampilkan daftar isi direktori pada web browser dengan menampilkan pesan error permission denied. Anehnya, ketika di direktori tersebut saya beri satu buah file index.html, ternyata file tersebut dapat tampil dengan baik. Berarti dari sini ketahuan bahwa masalahnya bukan terdapat pada file permission ataupun ownershipnya, karena buktinya file index.html dapat terbaca dengan baik.

Setelah melakukan trial and error selama beberapa hari, akhirnya saya mendapatkan solusinya. Caranya adalah sebagai berikut :

1. Anggap saja kalau direktori yang ingin saya perbolehkan ditampilkan isinya oleh apache berada di /home/sharing, maka edit dulu file /etc/apache2/apache2.conf :

# vim /etc/apache2/apache2.conf

Lalu tambahkan di baris paling bawah, script berikut :

<Directory /home/sharing>
Options Indexes FollowSymLinks
</Directory>


nb : sesuaikan letak /home/sharing dengan letak direktori milik kalian.

2. Setelah itu kalian juga perlu membuat sebuah file .htaccess didalam direktori /home/sharing. Perintahnya adalah sebagai berikut :

# vim /home/sharing

Tambahkan script berikut ini :

Options +Indexes

3. Terakhir restartlah service apache kalian :

# service apache2 restart

4. Dan, walaa! Direktori kalian pun kini sudah boleh diakses.


Semoga bermanfaat :)

SUMBER

17 March 2014

Install Converseen di Ubuntu 13.10

Converseen adalah salah satu aplikasi favorit saya di Ubuntu. Fungsinya adalah untuk mengkompres file-file gambar, dari yang awalnya beresolusi besar, menjadi gambar yang beresolusi kecil. Selain itu Converseen juga dapat mengkonversi dari satu tipe ekstensi file ke ekstensi lainnya, seperti dari gambar png ke jpg. Bagus deh pokoknya! :D

Bagi kalian yang ingin mencobanya, untuk menginstall Converseen di Ubuntu 13.10, silahkan ketikkan perintah berikut ini di terminal :

$ sudo add-apt-repository ppa:dhor/myway
$ sudo apt-get update
$ sudo apt-get install converseen



Semoga bermanfaat :)

SUMBER

14 March 2014

Daftar Fasilitas Kesehatan BPJS Kabupaten Tangerang

Terima kasih
dalam dunia kesehatan sekarang ini di Indonesia sudah mulai terasa keringanannya, dengan adanya BPJS ini kita bisa berobat gratis, tanpa harus bayar apapun. yang dibutuhkan hanya kartu BPJS Kesehatan. Dalam prakteknya jika seseorang mengalami gejala kurang sehat alangkah baiknya terlebih dahulu pergi ke klinik sesuai dengan apa yang kita tunjuk pas pembuatan kartu, karena ini merupakan hal yang mutlak sebelum masuk ke Rumah Sakit besar. klinik ini adalah klinik yang termuat di kartu BPJS Kesehatan. Jika klinik tersebut tidak sanggup menanganinya, klinik tersebut langsung merujuk ke Rumah Sakit terdekat sesuai keinginan kita. semoga bermanfaat. selengkapnya silahkan ke sini


BPJS KESEHATAN KABUPATEN TANGERANG

13 March 2014

Puppy Linux 5.7 "Slacko" - Released


Puppy Linux is yet another Linux distribution. What's different here is that Puppy is extraordinarily small, yet quite full-featured. Puppy boots into a ramdisk and, unlike live CD distributions that have to keep pulling stuff off the CD, it loads into RAM. This means that all applications start in the blink of an eye and respond to user input instantly.

Puppy Linux has the ability to boot off a flash card or any USB memory device, CDROM, Zip disk or LS/120/240 Superdisk, floppy disks, internal hard drive. It can even use a multisession formatted CD-RW/DVD-RW to save everything back to the CD/DVD with no hard drive required at all.

Puppy's Desktop
Puppy Linux 5.7 "Slacko" edition, a small and fast distribution built from and compatible with Slackware's binary packages, has been released as the "flagship" Puppy release. From the release announcement: "Slacko Puppy is built from a 'Puppy builder' system named Woof, which can build a Puppy Linux distribution from the binary packages of any other distro. There are many 'puppies' built with Woof, including Precise, Wary, Racy, and Slacko. A new release of Slacko Puppy Linux is out! Slacko Puppy is built from Slackware-14.0 binary TXZ packages, hence has binary compatibility with Slackware and access to the Slackware, Salix and Slacky package repositories. More comprehensive release notes and documentation of known issues are available. Slacko 5.7 is the first Puppy built from the woof-CE build system, forked from Barry Kauler's Woof late last year after he announced his retirement from Puppy development. It is the natural progression of Slacko 5.6 with the added features introduced to woof-CE." More links for readers to follow can be found on Barry Kauler's blog. Download: slacko-5.7-NO-pae.iso (161MB, MD5), slacko-5.7.0-PAE.iso (162MB, MD5).

Cara Export & Import Konfigurasi/Setingan Mikrotik

Export & Import Konfigurasi/Setingan Mikrotik hampir sama dengan melakukan backup & restore seperti yang sudah pernah saya bahas disini :  

Bedanya Export - Import dengan Backup - Restore :
1. File hasil backup tidak bisa dibuka di notepad PC, sedangkan file hasil export bisa.
2. File hasil export berisi script konfigurasi/setingan Mikrotik yang dapat langsung di copy-paste dan dieksekusi di terminal Mikrotik.

Jadi, fitur Export ini dapat digunakan untuk melihat konfigurasi Mikrotik dalam bentuk script (command line). File ini juga bisa digunakan untuk import konfigurasi Mikrotik, sama halnya dengan fungsi Backup - Restore Mikrotik.

Cara Export & Import Konfigurasi/Setingan Mikrotik sebagai berikut :
1. Buka terminal  masukkan command berikut :
export file=namafile
Ganti namafile sesuai keinginan anda.


Selain itu kita juga bisa melakukan export untuk konfigurasi spesifik, misal mau export konfigurasi firewall saja jadi command nya gini :
ip firewall export file=namafile
2. Hasil file export nya tersimpan di file, coba lihat dengan command 
file print

3. Untuk meng-copy file konfigurasi tersebut, buka menu file --> pilih file konfigurasi mana saja yang mau di-copy --> klik tombol copy di toolbar --> masuk ke folder Windows Explorer --> Paste di folder mana terserah anda.


4. Extensi file export ini adalah .rsc. Kita bisa membuka file ini dengan notepad.



5. Jika ingin meng-import file konfigurasi ini buka terminal --> ketikkan command :
import file-name=namafile

Oke, demikianlah tutorial mikrotik tentang Cara Export & Import Konfigurasi/Setingan Mikrotik.
Semoga bermanfaat :)

Cara Memblokir Penggunaan Web Proxy External di Mikrotik

Web Proxy external dapat digunakan untuk mem-bypass firewall dan membuka situs yang tadinya diblokir. Hal ini tentunya bisa bikin kita gigit jari, ketika sudah susah payah bikin sistem dengan firewall untuk memblokir situs macam-macam, ternyata client menggunakan proxy untuk mem-bypass firewall nya. Cape deh.. 

Nah, supaya client tidak bisa menggunakan proxy external untuk mem-bypass firewall, kita perlu memblokir penggunaan web proxy external dengan menggunakan Mikrotik. Caranya dengan membuat rule firewall mikrotik yang memblokir penggunaan port proxy. Hal ini dapat mencegah user/client untuk menggunakan proxy.

Ok, langsung saja ya ikuti Cara Memblokir Penggunaan Web Proxy External di Mikrotik berikut ini :
1. Jika anda menggunakan web proxy internal di Mikrotik, pastikan port nya diganti ke port yang tidak biasa dipake proxy, misalnya port 88


2. Jika anda menggunakan mode transparent proxy, pastikan port redirect nya juga sudah diganti ke port baru, misalnya port 88



3. Buat rule firewall baru dengan melakukan "drop" semua port yang digunakan oleh proxy. Anda bisa copy - paste script berikut ini di terminal :
/ip firewall filter
add action=drop chain=forward comment="Blokir Proxy Port #1" dst-port=\
    3128,54321,6515,6666,8000,8001,8008,808,8080,8081,8088 protocol=tcp \
    src-address=0.0.0.0/0
add action=drop chain=forward comment="Blokir Proxy Port #2" dst-port=\
    8090,81,8118,8181,82,83,84,85,86,8888,8909,9000,9090 protocol=tcp \
    src-address=0.0.0.0/0
4. Jika anda menemukan port lain yang digunakan proxy, silakan ditambahkan sendiri ya.

5. Berikut contoh penggunaannya ketika saya mencoba membuka sebuah web yang diblokir :
=> Sebelum menggunakan proxy

=> Menggunakan proxy

=> Setelah port proxy di "drop"

Nah, jadi dengan trik ini kita bisa mencegah user/client untuk menggunakan proxy selama port proxy yang mereka gunakan sudah masuk ke daftar blokir. 
Oke, demikianlah tutorial mikrotik tentang Cara Memblokir Penggunaan Web Proxy External di Mikrotik. Silakan dicoba dan semoga bermanfaat :)

10 March 2014

Cara Konfigurasi Internet Speedy di Mikrotik

Jika kalian adalah pengguna Speedy sebagai koneksi ISP ke Mikrotik, tentunya kalian sudah tidak asing lagi dengan istilah koneksi dengan metode Bridge. Bagi kalian yang belum tahu apa itu metode koneksi Bridge, intinya ini adalah metode koneksi agar router Mikrotik-lah yang melakukan dial ke pihak ISP, sehingga Mikrotik juga yang akan mendapatkan IP Publik dari ISP. Karena jika kita tidak menggunakan metode Bridge ini, maka nanti si modem-lah yang mendapatkan IP Publik, bukannya si Mikrotik. Tentunya ini akan menyulitkan kita ketika kita ingin meremote router mikrotik kita dari Internet.

Nah, metode agar si Mikrotik dapat melakukan dial (menelpon) ke ISP ini disebut koneksi PPPoE (Point to Point Protocol over Ethernet) Client. Pada artikel ini akan saya jelaskan step by step untuk melakukan konfigurasi PPPoE di Mikrotik.

Yang harus disiapkan

1. Modem sudah harus disetting sebagai mode Bridge. Silahkan cari saja di google, sudah banyak kok yang membahas cara setting modem Speedy agar menjadi mode Bridge. Intinya adalah kalian tinggal akses modem kalian (biasanya alamatnya 192.168.1.1 dengan username : admin dan password : admin) lalu cari settingan yang ada Bridge-Bridgenya gitulah.


2. Pastikan kalian sudah memiliki username dan password yang diberikan oleh pihak Speedy.
3. Mengetahui cara pengoperasian Mikrotik melalui Winbox. Download software winbox disini.
4. Sudah mengkonfigurasi IP Address Mikrotik. Lihat caranya disini jika kalian belum tahu.

Topologi

internet --- modem ---- (ether1-internet)Mikrotik(ether2-lokal --- LAN

Konfigurasi

1. Silahkan login ke Mikrotik kalian menggunakan Winbox. Kemudian akses menu Interface > klik tanda Panah tepat disamping tanda (+) > PPPoE Client.


2. Konfigurasinya adalah sebagai berikut :

General
Name : Diisi Bebas, misal PPPoE-Spidol
Max MTU : Biarkan
Max MRU : Biarkan
Interface : ether1-internet (Ini adalah interface yang mengarah ke modem Speedy)

Dial Out
User : 1234567@telkom.net ---> Sesuai yang diberikan pihak Speedy
Password : dx647483 ---> Sesuai yang diberikan pihak Speedy

Jika sudah klik Apply.


Setelah itu pastikan pada bagian IP > Address sudah muncul IP Publik yang didapatkan oleh interface PPPoE-Spidol.

Semoga bermanfaat :)

SUMBER

06 March 2014

Convert Multi Image Dengan Satu Baris Perintah

Adakalanya kita harus mengonvert banyak file image untuk keperluan tertentu. Umumnya kita melakukan konversi tersebut adalah karena file-file yang  dimaksud memiliki ukuran yang relative besar.

Untuk kebutuhan blog atau website misalnya, kita membutuhkan file-file yang memiliki volume kecil, tetapi file yang kita miliki memiliki ukuran yang besar, sehingga kita harus meresize ukurannya.

Jika itu cuma satu atau beberapa file, mungkin tidak menjadi masalah. Lalu bagaimana jika file yang harus kita resize tersebut puluhan atau ratusan?

Salah satu caranya adalah dengan menggunakan imagemagick. Kita bisa menggunakan baris perintah berikut :

for file in *.jpg; do convert -resize 800x600 -- "$file" "${file%%.jpg}-resized.jpg"; done
 
Perintah tersebut akan meresize file image menjadi 800x600 px dan memberikan nama file baru *-resized.jpg

Masih bingung? Coba lihat ini
Resize *.jpg - 800x600px & rename ke *-resized.jpg
Dari ilustrasi diatas bisa kita liat bahwa semua file *.jpg di resize dan mendapatkan nama baru menjadi *.resized.jpg tentunya dengan volume yang jauh lebih kecil.

Demikian

05 March 2014

Virus Ramnit dan Timbul Shortcut.ink

pernahkah anda mengenal virus ramnit atau yang lebih dikenal lagi virus seperti berikut :
shortcut1.ink
shortcut2.ink
shortcut3.ink
shortcut4.ink
dan muncul folder recycle dengan sendiri.


jika gejalanya seperti di atas. dengan berat hati anda terkena virus ramnit. virus ini menyerang seluruh program yang ada harddisk yang ada di komputer, bukan hanya akan menggelembungkan volume flashdisk yang terjangkit virus ini. harddisk juga akan penuh dengan sendirinya.

03 March 2014

Download BBM untuk Gingerbread Samsung Galaxy Young

Postingan singkat pada malam hari ini. Saya hanya ingin membagikan link download untuk aplikasi BBM atau Blackberry Messenger untuk OS Android yang masih Gingerbread. Tentunya saya sudah tidak perlu lagi menjelaskan apa itu aplikasi BBM, ataupun kenapa disini saya hanya membagikan link BBM untuk Gingerbread saja. Saya rasa kalian semua pasti sudah tau sebelum kalian nyasar ke artikel ini.

Untuk mendownload BBM untuk Gingerbread Samsung Galaxy Young, silahkan klik link dibawah ini :


Cara installnya tinggal kalian pindahkan file .apk yang sudah didownload ke sdcard Android kalian. Setelah itu tinggal kalian klik saja filenya, lalu pilih Install. 




Semoga bermanfaat :)

01 March 2014

Mengedit File PDF di Ubuntu dengan Master PDF Editor



Dulu banyak teman saya yang sering bertanya kepada saya begini, "zal, cara ngedit file pdf di Ubuntu pakai software apa sih?". Nah, bagi kalian yang juga mempunyai pertanyaan yang sama dengan teman-teman saya tersebut, kali ini saya akan membagikan sedikit tips untuk kalian tentang cara Mengedit File PDF di Ubuntu.

Nama aplikasi yang kita butuhkan adalah Master PDF Editor. Aplikasi ini bisa mengedit file-file pdf maupun xps seperti menambahkan teks, gambar, menggabungkan halaman, menghapus halaman, dan sebagainya. Saya sendiri sudah coba, dan memang bagus kok fitur-fiturnya. Selain itu, aplikasi ini benar-benar dapat membuka file pdf sesuai aslinya, tidak ada cacat sama sekali seperti misalnya kita membuka file docx pada Libre Office.



Untuk menginstallnya di Ubuntu, kalian cukup download file .deb nya disini, kemudian klik 2x file tersebut sehingga akan muncul menu instalasi melalui Ubuntu Software Center. Selanjutnya tinggal klik Install dan tunggu prosesnya sampai selesai. Atau bagi kalian yang lebih suka untuk menginstallnya melalui terminal, cukup letakkan file master-pdf-editor_1.9.23_i386.deb yang sudah kalian download di home folder kalian, lalu ketikkan perintah berikut ini :

$ sudo dpkg -i master-pdf-editor_1.9.23_i386.deb

Semoga bermanfaat :)

SUMBER